Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154342 - skiplist collides with Quicktime
Summary: skiplist collides with Quicktime
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: file
Version: 3
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Radek Vokal
QA Contact: Mike McLean
URL:
Whiteboard:
: 148808 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-10 14:05 UTC by elias
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-11 08:47:24 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 148808 None None None Never

Internal Links: 148808

Description elias 2005-04-10 14:05:20 UTC
Description of problem:

Skiplist db files, used in cyrus-imapd, are identified as "Apple QuickTime movie
(modified)". This creates problems in cyrus-imapd startup, which uses file to
discern whether the db files are skiplist or berkeley, when it calls
/usr/lib/cyrus-imapd/cvt_cyrusdb_all, see bug #148808

Version-Release number of selected component (if applicable):


file-4.12-1.FC3.1
How reproducible:


Steps to Reproduce:
1. Have cyrus-imapd installed  
2. Create mailboxes
3. Do "file /var/lib/imap/mailboxes.db"
  
Actual results:

/var/lib/imap/mailboxes.db: Apple QuickTime movie (modified)

Expected results:

/var/lib/imap/mailboxes.db: Cyrus skiplist DB

Additional info:

cd /usr/share/file
edit the file "magic" and move lines 6460-6462 to line 250-252, save and do
"file -C"

Comment 1 Radek Vokal 2005-04-11 08:47:24 UTC
Fixed, Cyrus mail files have now greater priority than Apple Quicktime movies.
file-4.13-4

Comment 2 John Dennis 2005-04-23 20:03:47 UTC
*** Bug 148808 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.