Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154333 - Anaconda graphical install fails to start on imac 333
Summary: Anaconda graphical install fails to start on imac 333
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-10 06:31 UTC by Clinton Goudie-Nice
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-27 20:23:41 UTC


Attachments (Terms of Use)

Description Clinton Goudie-Nice 2005-04-10 06:31:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
I've got an imac 333 (revision 2.2 with the newworld rom, according to cpuinfo) with 320mb ram.

When I try to install using the boot.iso cd to boot the box, and then switch over to the FC4 CDs to install, when it tries to start the graphical installer, the system appears to hang.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot with the boot.iso from the first CD.
2. Select CD install, and put in FC4-Test1 Disc 1
3. Continue, and the machine appears to hang.
  

Actual Results:  caps lock still turns the caps lock light on and off, but ctrl-alt-f# doesn't switch the console, and the machine never appears to continue past that point.

Additional info:

By booting the box as linux text from the boot.iso, I was able to install in plain text mode.

Comment 1 Clinton Goudie-Nice 2005-04-10 19:23:41 UTC
It's worth noting that when I try to boot the box after the install, it does 
this same thing, even if I disable rhgb.

After going through some of the startup steps, and soon after the udev starting 
audio network storage, etc... the machine freezes in the same way. Just a solid 
underscore cursor in the upper left, and nothing more.

Just for comparison YDL 4.0 starts up anaconda on this box just fine.

Comment 2 Paul Nasrat 2005-04-11 09:06:05 UTC
Does installing with resolution=1024x768 enable graphical installation (x config
may not be correct still - but there is another bug for that).





Comment 3 Clinton Goudie-Nice 2005-04-12 04:35:44 UTC
nope. I tried starting it with the boot line linux resolution=1024x768, and it 
still get's the the Starting X 1... 2... <lock with solid underscore cursor in 
upper right corner> and I can't change to the other ttys to see what is going 
on.

Just before it hung I was looking through the other ttys and I did see starting 
X additional arguments --resolution 1024x768 (or something to that effect)

Also of note:

results of lspci from cd install on tty 2

00:00.0 Host bridge: Morotola MPC106 [Grackle] (rev 40)
00:10.0 Class ff00: Apple Computer Inc. Paddington Mac I/O
00:12.0 VGA compatable controller: ATI Technologies Inc 3D Rage Pro 215GP (rev 
5c)
00:14.0 USB Controller: OPTi Inc. 82C861 (rev 10)

Comment 4 Clinton Goudie-Nice 2005-04-12 14:54:00 UTC
Same thing happens with Test2. Right as it starts X, everything goes in the can.

Comment 5 Clinton Goudie-Nice 2005-04-13 22:53:54 UTC
Any ideas on some other flags I could try and see if X starts correctly?

Comment 6 Clinton Goudie-Nice 2005-04-17 05:35:38 UTC
My comments about turning off RHGB wern't correct. Once I disable rhdb and run 
ybin, the box will boot.

However, any attempt to start X will hang the box.

I up2dated today to try again withthe same result... I've also tried playing 
with the color depth in the xorg.conf, setting it up to 32 to no avail.

Comment 7 Clinton Goudie-Nice 2005-04-17 20:35:16 UTC
Aha I've got it. The device section is like so:

Section "Device"
        Identifier  "Videocard0"
        Driver      "fbdev"
        VendorName  "Videocard vendor"
        BoardName   "Framebuffer driver (generic)"
EndSection

It's not trying to use the ati driver.

Changing it to use the ATI driver and changing the resolution and color depth 
to 1024x768 and 24bit color and it starts up.

Comment 8 Chris Lumens 2006-02-27 20:23:41 UTC
This is working on our iMacs with FC5test3.


Note You need to log in before you can comment on or make changes to this bug.