Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154332 - kudzu doesn't "detect" Apple BMAC
Summary: kudzu doesn't "detect" Apple BMAC
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kudzu
Version: rawhide
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-10 06:22 UTC by Clinton Goudie-Nice
Modified: 2014-03-17 02:53 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-28 15:34:59 UTC


Attachments (Terms of Use)
patch against kudzu 1.2.57.1 to enable bmac ethernet autodetection (deleted)
2006-10-20 07:06 UTC, Dan Bethe
no flags Details | Diff
search for both (deleted)
2006-10-20 19:37 UTC, Bill Nottingham
no flags Details | Diff

Description Clinton Goudie-Nice 2005-04-10 06:22:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
I've got an imac 333 (revision 2.2 with the newworld rom, according to cpuinfo) with 320mb ram.

When I try to boot with the boot.iso from disc one to do an nfs install it says it cant find any ethernet drivers. The ethernet is built onto this model of imac.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. boot an imac 333 with the boot.iso and try to do an nfs install
2. It doesn't find the nic
3.
  

Additional info:

Comment 1 Jeremy Katz 2005-04-10 20:59:01 UTC
Do you know what kind of network chip is in the machine?  Can you start a CD
install and switch to tty2 and run lspci?

Comment 2 Clinton Goudie-Nice 2005-04-11 04:36:22 UTC
results of lspci from cd install on tty 2

00:00.0 Host bridge: Morotola MPC106 [Grackle] (rev 40)
00:10.0 Class ff00: Apple Computer Inc. Paddington Mac I/O
00:12.0 VGA compatable controller: ATI Technologies Inc 3D Rage Pro 215GP (rev 
5c)
00:14.0 USB Controller: OPTi Inc. 82C861 (rev 10)

The exact same results are returned from YDL 4.0

Comment 3 Clinton Goudie-Nice 2005-04-11 04:41:45 UTC
YDL 4.0 system-config-network says the hardware is:
eth0 (GMAC (Sun GEM))

Comment 4 Paul Nasrat 2005-04-11 09:04:12 UTC
Can you check tty 3 4 and 5 when it complains about no network device.  I think
this may be an issue on some hardware where when we probe, we don't find the device.

Comment 5 Clinton Goudie-Nice 2005-04-12 03:55:04 UTC
I checked the other ttys and couldn't see anything that I associated with being 
unable to load the ethernet drivers. On a whim I chose the select a driver 
option and tried the Apple BMAC driver which lit up, got an address from dhcp, 
and appeared able to mount the NFS. Unfortunately it then said "This directory 
does not appear to contain a fedora installation tree." I suspect this is a 
different bug and I'll log it as such.

Looks like something just needs to plug together the devices in this machine 
and the Apple BMAC driver.

Comment 7 Paul Nasrat 2005-04-12 15:39:04 UTC
Actually this might be the ones that don't show up in pci until the module is
loaded.  I'll test on fish/g3 bmac tomorrow in Cambridge.




Comment 8 Dan Bethe 2006-10-20 07:06:11 UTC
Created attachment 138944 [details]
patch against kudzu 1.2.57.1 to enable bmac ethernet autodetection

Provided to me by dwmw2 (David Woodhouse) of #fedora-ppc on freenode.

Comment 9 Dan Bethe 2006-10-20 07:09:32 UTC
Comment on attachment 138944 [details]
patch against kudzu 1.2.57.1 to enable bmac ethernet autodetection

See this patch to fix the bmac driver, both attached here and in the following
url.

http://david.woodhou.se/kudzu-1.2.57.1-find-bmac.patch

Also see the script I wrote which helps to automate the installation of PPC
Fedora Core on another FC based host of that or any other architecture.  This
is especially useful when installing on unsupported OldWorld Macintosh.  This
is my first draft and it Works For Me(tm) so please let me know your thoughts.

http://smuckola.org/projects/ppc_fc.sh

Comment 10 David Woodhouse 2006-10-20 09:25:39 UTC
The patch looks for 'bmac' _instead_ of 'ethernet' in the device-tree. I suspect
we should be looking for _either_, but I was being lazy.

Comment 11 Paul Nasrat 2006-10-20 09:56:12 UTC
Possibly we should look across all device_types properties for network.

Comment 12 Bill Nottingham 2006-10-20 19:37:10 UTC
Created attachment 139024 [details]
search for both

From a quick read, minifind just adds to the passed in list, so calling it
twice in a row should be additive. Does this patch work for you?

Comment 13 Bill Nottingham 2007-11-28 15:34:59 UTC
This should be fixed for a while now.


Note You need to log in before you can comment on or make changes to this bug.