Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154321 - Vim profile script is still broken
Summary: Vim profile script is still broken
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: vim
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: FC4Target
TreeView+ depends on / blocked
 
Reported: 2005-04-09 21:22 UTC by Ivan Gyurdiev
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-11 09:38:42 UTC


Attachments (Terms of Use)
patch fixing unwanted expansion (deleted)
2005-04-10 16:13 UTC, Ronny Buchmann
no flags Details | Diff

Description Ivan Gyurdiev 2005-04-09 21:22:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050328 Firefox/1.0.2 Fedora/1.0.2-3

Description of problem:
  [ 100 -le 100 ] && return

What is this supposed to accomplish? It's always true,
which defeats the purpose of the rest of the script.

Prior to this the script was checking if I'm root,
and disabling the alias for root - I couldn't figure
out why it does that either.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:


Additional info:

Comment 1 Ronny Buchmann 2005-04-10 16:10:25 UTC
>Description of problem:
>  [ 100 -le 100 ] && return
this is a bug in the spec file

it should read 
cat >$RPM_BUILD_ROOT/etc/profile.d/vim.sh <<'EOF'

> Prior to this the script was checking if I'm root,
> and disabling the alias for root - I couldn't figure
> out why it does that either.
Maybe because of not trusting modelines?

This could be done with alias vi=vim -c "set nomodeline"

So why is the alias disabled for system users/root?



Comment 2 Ronny Buchmann 2005-04-10 16:13:10 UTC
Created attachment 112926 [details]
patch fixing unwanted expansion

Comment 3 Karsten Hopp 2005-04-11 09:38:42 UTC
expansion fixed in in vim-6.3.068-2   


Note You need to log in before you can comment on or make changes to this bug.