Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154315 - nss_ldap brokeness prevention attempt
Summary: nss_ldap brokeness prevention attempt
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: dovecot
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Petr Rockai
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC4Target 222110
TreeView+ depends on / blocked
 
Reported: 2005-04-09 18:21 UTC by Timo Sirainen
Modified: 2014-01-21 22:51 UTC (History)
2 users (show)

Fixed In Version: 0.99.14-8.fc4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-04-03 19:50:28 UTC


Attachments (Terms of Use)
Extra check (deleted)
2005-04-09 18:21 UTC, Timo Sirainen
no flags Details | Diff

Description Timo Sirainen 2005-04-09 18:21:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

Description of problem:
Please apply included patch which tries to prevent bug 154314 from breaking too badly.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:

Comment 1 Timo Sirainen 2005-04-09 18:21:55 UTC
Created attachment 112915 [details]
Extra check

Comment 2 Warren Togami 2005-04-10 02:55:18 UTC
Worthwhile to add error checking to dovecot, although this doesn't solve the
real problem in nss_ldap (Bug #154314).

Comment 3 Warren Togami 2005-05-23 03:38:49 UTC
I held back from applying this because of concern that it would hide the problem
rather than solving it.  Though I suppose it really doesn't... it would catch
the problem and give an error message.

Comment 4 Petr Rockai 2006-01-31 12:42:22 UTC
Do we want to get this into FC3 updates? Not overly likely considering how    
long this bug was in hiatus... Anyhow, if someone thinks it is worth it,    
please tell me. Regardless of that, an FC4 update with 1.0 beta 2 will be    
released in near future and FC5 will have the same, so this bug is not a   
concern for these releases. 

Comment 5 Petr Rockai 2006-03-28 08:33:02 UTC
Plan to make fc4 update with dovecot 1.0beta was dropped for now, so patching 
fc4 version now. FC3 is no longer updated and the problem is apparently not too 
widespread either.

Comment 6 Petr Rockai 2006-04-03 19:50:28 UTC
The fix was released as an update for fc4. The fc5 version is not affected. 
Closing.


Note You need to log in before you can comment on or make changes to this bug.