Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154308 - apt needs to upgrade mkinitrd *before* installing kernel
Summary: apt needs to upgrade mkinitrd *before* installing kernel
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: apt
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-09 16:45 UTC by Al Grabauskas
Modified: 2014-01-21 22:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-11 18:22:37 UTC


Attachments (Terms of Use)

Description Al Grabauskas 2005-04-09 16:45:51 UTC
firstly, this may not be the right place to report this - if not, my apologies,
advice on a better place would be welcome. i figured i'd start here even tho
apt-rpm isn't necessarily "official", and work my way to the appropriate folks
if needed. it's a minor problem, but i'd like to get it reported appropriately
anyway.

Description of problem:

in prep for doing an "apt-get dist-upgrade" fc2 to fc3 (i know that's not
supported, but it's relevant background) i did and "apt-get install
kernel#2.6.10-1.770_FC3". apt determined that it needed to upgrade mkinitrd as
well. but the kernel was installed before mkinitrd which resulted in a problem
running mkinitrd in the process of installing the kernel (output pasted below).

mkinitrd installed ok afterwards, and removing/re-adding that version of the
kernel worked fine.

Version-Release number of selected component (if applicable):

apt-0.5.15cnc6-4.1.fc2.rf

How reproducible:

see above

Steps to Reproduce:
 
see above
  
Actual results:

initial failure:

[root@lap archives]# apt-get install kernel#2.6.10-1.770_FC3
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
  mkinitrd
The following packages will be upgraded
  mkinitrd
The following NEW packages will be installed:
  kernel#2.6.10-1.770_FC3
1 upgraded, 1 newly installed, 0 removed and 736 not upgraded.
Need to get 0B/17.1MB of archives.
After unpacking 46.0MB of additional disk space will be used.
Do you want to continue? [Y/n]
Committing changes...
Preparing...                ########################################### [100%]
   1:kernel                 ########################################### [ 50%]
Usage: new-kernel-pkg [-v] [--mkinitrd] [--rminitrd]
       [--initrdfile=<initrd-image>] [--depmod] [--rmmoddep]
       [--kernel-args=<args>] [--banner=<banner>]
       [--make-default] <--install | --remove> <kernel-version>
       (ex: new-kernel-pkg --mkinitrd --depmod --install 2.4.7-2)
   2:mkinitrd               ########################################### [100%]
Done.

---------------------------------------------

removing and installing the kernel worked ok once mkinitrd was upgraded:

[root@lap archives]# apt-get remove kernel#2.6.10-1.770_FC3
Reading Package Lists... Done
Building Dependency Tree... Done
The following packages will be REMOVED:
  kernel#2.6.10-1.770_FC3
0 upgraded, 0 newly installed, 1 removed and 736 not upgraded.
Need to get 0B of archives.
After unpacking 46.0MB disk space will be freed.
Do you want to continue? [Y/n]
Committing changes...
Preparing...                ########################################### [100%]
Done.


[root@lap archives]# apt-get install kernel#2.6.10-1.770_FC3
Reading Package Lists... Done
Building Dependency Tree... Done
The following NEW packages will be installed:
  kernel#2.6.10-1.770_FC3
0 upgraded, 1 newly installed, 0 removed and 736 not upgraded.
Need to get 0B/17.0MB of archives.
After unpacking 46.0MB of additional disk space will be used.
Committing changes...
Preparing...                ########################################### [100%]
   1:kernel                 ########################################### [100%]
Done.


Expected results:


Additional info:

Comment 1 Sitsofe Wheeler 2005-04-10 10:02:08 UTC
This is the wrong place for this query since Red Hat have never shipped apt in
Fedora. If you do:
rpm -qi apt-0.5.15cnc6-4.1.fc2.rf
This should tell you the contact information for that RPM (try emailing the
packager).

Basically you need to ask for help on apt (or apt related problems) from whoever
you got that apt RPM from.

Comment 2 Seth Vidal 2005-04-11 18:22:37 UTC
Okay, super-duper certain that this isn't a yum issue.

closing.


Note You need to log in before you can comment on or make changes to this bug.