Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1543062 - Auto-sync - additional OVN cluster on DC does not consume OVN network as expected
Summary: Auto-sync - additional OVN cluster on DC does not consume OVN network as expe...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network
Version: future
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: ovirt-4.2.4
: ---
Assignee: Dominik Holler
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On:
Blocks: 1511823
TreeView+ depends on / blocked
 
Reported: 2018-02-07 16:29 UTC by Mor
Modified: 2018-06-26 08:39 UTC (History)
2 users (show)

Fixed In Version: ovirt-engine-4.2.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-26 08:39:10 UTC
oVirt Team: Network
rule-engine: ovirt-4.2+
ylavi: exception+


Attachments (Terms of Use)
logs (deleted)
2018-02-07 16:30 UTC, Mor
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 87605 master MERGED core: Sync external network in new cluster 2018-03-20 07:43:34 UTC
oVirt gerrit 89274 ovirt-engine-4.2 MERGED core: Sync external network in new cluster 2018-04-26 06:08:58 UTC
oVirt gerrit 90655 model_4.2 MERGED Document new update feature of auto_sync 2018-05-04 06:34:10 UTC
oVirt gerrit 90891 model_4.2 MERGED Document new update feature of auto_sync 2018-05-04 06:34:31 UTC

Description Mor 2018-02-07 16:29:31 UTC
Description of problem:
On existing DC with 'ovirt-provider-ovn' cluster, if you add additional 'ovirt-provider-ovn' cluster (or edit existing one from no provider --> 'ovirt-provider-ovn'), it will not consume (under Compute --> clusters--> <cluster_name> --> Logical networks tab) OVN networks as expected.

Version-Release number of selected component (if applicable):
RHV 4.2.1.5-0.1.el7

How reproducible:
100%

Steps to Reproduce:
1. Create DC with 'ovirt-provider-ovn' cluster.
2. Create OVN network on the provider and wait for it to sync.
3. Create new 'ovirt-provider-ovn' cluster on DC from step 1.
4. Wait for the OVN network to appear under Logical Networks within the cluster from step 3.

Actual results:
No OVN networks are attached to the new cluster. Auto-sync checks if the network exists per DC.

Expected results:
OVN networks should be attached to the new cluster. Check should be made per cluster.

Additional info:

Comment 1 Mor 2018-02-07 16:30:43 UTC
Created attachment 1392780 [details]
logs

Comment 2 Michael Burman 2018-05-28 07:54:12 UTC
Verified on - 4.2.4-0.1.el7

Comment 3 Sandro Bonazzola 2018-06-26 08:39:10 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.