Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154300 - Invalid URI error when opening file
Summary: Invalid URI error when opening file
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 3
Hardware: x86_64
OS: Linux
medium
low
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL: file:///
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-09 13:05 UTC by Chris Underhill
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-09 16:04:44 UTC


Attachments (Terms of Use)

Description Chris Underhill 2005-04-09 13:05:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
Using the i386 rpm of firefox on my x86_64 box, I get a popup error window when I type CTRL-O or perform any other action that invokes the Gnome file browser, such as browsing files for upload. It contains the text

Could not retrieve information about file:///<whatever>: error accessing 'file:///<whatever>': Invalid URI.

The x86_64 build does not have this problem. Also if I enter file:///<whatever> in the url bar at the top however, it works fine as well. 

I suspect a missing i386 version of a library which the dependency checking in rpm is missing as I have the x86_64 version.  

Version-Release number of selected component (if applicable):
firefox-1.0.2-1.3.1

How reproducible:
Always

Steps to Reproduce:
1. Open 32bit version of firefox
2. Press CTRL-O
3.
  

Actual Results:  See error popup

Expected Results:  See Gnome file browser popup. If click through the error, the file dialog does appear but the error popup appears again if you click on anything in the left hand pane.

Additional info:

The problem arises even with no extensions or plugins loaded and with a new profile.

Comment 1 Chris Underhill 2005-04-09 16:04:44 UTC
Found the problem - my suspicion was correct: Installing
gamin-0.0.25-1.FC3.i386.rpm fixed things.


Note You need to log in before you can comment on or make changes to this bug.