Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154299 - iptables-1.3.0 breaks ipac-ng 1.31
Summary: iptables-1.3.0 breaks ipac-ng 1.31
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: iptables
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-09 11:35 UTC by Thomas Zehetbauer
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-11 15:34:02 UTC


Attachments (Terms of Use)

Description Thomas Zehetbauer 2005-04-09 11:35:19 UTC
After updating to Fedora Core 4 Test 1 my ipac-ng stopped working. From what I
see it calls xcalloc() from prepare_entry()/iptables.c:1279 that fails because
of an  insane target->size value in the preceding line. Unfortunately I could
not figure out where this value is coming from but downgrading to
iptables-1.2.11 solves the problem.

Upstream Report: https://bugzilla.netfilter.org/bugzilla/show_bug.cgi?id=320

Comment 1 Thomas Woerner 2005-05-11 15:34:02 UTC
Upstream report:

This needs to be fixed in ipac-ng, as noted in the reply you received on the
ipac-ng mailing list:

"somebody has to work to make ipac-ng use iptables header properly instead of
assuming it may work with a particular iptables header version."

Closing as "NOT A BUG".


Note You need to log in before you can comment on or make changes to this bug.