Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154297 - gnome-games rpm doesnt depend on guile
Summary: gnome-games rpm doesnt depend on guile
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-games
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-09 10:11 UTC by Jacob Kroon
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-10 21:27:45 UTC


Attachments (Terms of Use)

Description Jacob Kroon 2005-04-09 10:11:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050328 Firefox/1.0.2 Fedora/1.0.2-3

Description of problem:
When starting "Aisleriot Solitaire" I get errors in /tmp/xses-???:

sol: error while loading shared libraries: libguile.so.12: cannot open shared object file: No such file or directory

and the application doesn't start.

Version-Release number of selected component (if applicable):
gnome-games-2.9.6-1

How reproducible:
Always

Steps to Reproduce:
1. Install gnome-games on a system without guile installed

Actual Results:  Can't start Aisleriot Solitaire, and possibly more of the solitaire games.

Expected Results:  Game should popup and I can play away...

Additional info:

The problem is solved by installing the guile rpm.
Perhaps the gnome-games rpm should depend on guile ?

Also, once guile is installed, I get warning messages about missing GConf keys the first time I start Aisleriot Solitaire. The window looks abnormally small, which probably is related to the missing GConf-keys.

Comment 1 Warren Togami 2005-04-10 21:27:45 UTC
libguile.so.12()(64bit) is needed by (installed) gnome-games-2.9.6-1.x86_64

This is not a bug anymore.  This was likely a problem because the earlier guile
was built at the same time as gnome-games in FC4test1, so they became as
gnome-games linked to the earlier version while a new guile also went into FC4.


Note You need to log in before you can comment on or make changes to this bug.