Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154291 - kernel gets wedged when removing airo module while in use
Summary: kernel gets wedged when removing airo module while in use
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-09 02:22 UTC by Havoc Pennington
Modified: 2015-01-04 22:18 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-06 20:16:35 UTC


Attachments (Terms of Use)

Description Havoc Pennington 2005-04-09 02:22:18 UTC
This sounds like a "don't do that then" but it happens in real situations with
networkmanager

So the simple reproducer is:

 - bring up eth0 which is a wireless airo
 - "rmmod airo"
 - hangs with "unregister_netdevice: waiting for usage count to be 0"
 - all network-related processes are now locked up, so you can't 
   do anything to bring the usage count to 0
 - you can't kill any of the network-related processes
 - you have to reboot afaict

If you do the rmmod after an "ifdown eth0" then it works fine.

The reason this happens with NetworkManager is basically:
 - across suspend/resume the airo driver gets confused out of its mind
 - without NetworkManager you can work around this by "ifdown eth0; rmmod airo; 
   ifup eth0"
 - with NetworkManager you can't do the "ifdown" part of the workaround so it 
   would be convenient if "rmmod airo" worked with the interface still up, 
   or "rmmod airo; killall NetworkManager" worked

There are probably better fixes, like:
 - have the airo driver not get confused when you suspend
 - have NetworkManager bring down the interface on suspend

Anyway, something is hosed, feel free to bounce this buck around ;-)

Thanks

Comment 1 Dan Williams 2005-04-10 12:05:46 UTC
I fixed a bug last week which caused 1 file descriptor to get leaked every DHCP transaction on the 
device.  That might have been the problem.

Comment 2 Dan Williams 2005-04-10 12:08:08 UTC
Also note that if you send NM the "sleep" message, it will shut down all devices and essentially "ifdown" 
them.  If you send it "awake", it will re-enable them and find a new connection.  You have to add it to 
your suspend/resume scripts, because nothing in the system broadcasts shutdown/wake events or 
anything.

Comment 3 Dave Jones 2005-10-06 05:27:51 UTC
still a problem with latest errata ?


Comment 4 Dan Williams 2005-10-06 15:28:00 UTC
Most likely a firmware issue, should update to 5.60.08 or later.


Note You need to log in before you can comment on or make changes to this bug.