Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154287 - Nautilus won't display thumbnails of some jpeg files , but displays default image icon instead
Summary: Nautilus won't display thumbnails of some jpeg files , but displays default i...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-09 00:53 UTC by Stephen Warren
Modified: 2013-03-06 03:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-09 20:58:06 UTC


Attachments (Terms of Use)
A sample jpeg file that nautilus won't display a thumbnail for. (deleted)
2005-04-09 00:55 UTC, Stephen Warren
no flags Details

Description Stephen Warren 2005-04-09 00:53:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
I have a large number of photos in a directory tree. A lot of these are .jpeg files, from "Photo CDs" (from film developing) and from a number of digital cameras. When in "icon" view, Nautilus typically displays icons that show thumbnails of the images. However, for some valid jpeg files, it won't display a thumbnail, but instead displays the system's default "jpeg" icon instead.

Note that switching to "catalog" view *does* display a valid thumbnail, and switching back to icon view "forgets" that thumbnail again. Catalog view is not a useful work-around, since files can't be selected/cut/paste/right-clicked/dragged, thus making that view quite useless (btw, what *is* it's purpose?)

When I double-click the file to view the problem images in an image viewer, they are displayed correctly.

Note that I think I'm only seeing this problem on jpeg files from a "Canon Powershot Pro1", and even then, only on a seemingly arbitrary subset of the files (*but* a precisely reproducable subset - i.e. it's always the same set of file no matter whether I log out and back in, or delete files from ~/.thumbnails or ~/.nautilus/metafiles)

None of these fix the problem: F5, CTRL-R,  the "Refresh" graphical button, nor View/Reload menu.

Version-Release number of selected component (if applicable):
nautilus-2.8.1-4 rpm

How reproducible:
Always

Steps to Reproduce:
1. Run Nautilus
2. Browse to a directory containing jpeg files
3. Put Nautilus into icon mode
  

Actual Results:  Only some icons are thumbnails of the images - others display the system's default "jpeg" icon.

Expected Results:  All icons should be image thumbnails.

Additional info:

Comment 1 Stephen Warren 2005-04-09 00:55:47 UTC
Created attachment 112897 [details]
A sample jpeg file that nautilus won't display a thumbnail for.

Comment 2 Sitsofe Wheeler 2005-04-09 20:50:33 UTC
That picture is pretty big so you are probably hitting the preview limit
(nautilus won't create previews for files over a certain size).

In a nautilus window go to Edit -> Preferences then Preview to see what I mean.

Comment 3 David Zeuthen 2005-04-09 20:58:06 UTC
Indeed, as pointed out in comment 2, this is a feature, not a bug.


Note You need to log in before you can comment on or make changes to this bug.