Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154266 - Unable to set second audio device as default
Summary: Unable to set second audio device as default
Keywords:
Status: CLOSED DUPLICATE of bug 134316
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-soundcard
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-08 21:03 UTC by Sean Bruno
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-11 16:12:52 UTC


Attachments (Terms of Use)

Description Sean Bruno 2005-04-08 21:03:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050328 Firefox/1.0.2 Fedora/1.0.2-3

Description of problem:
My machine has an on-board audio device and I have added a USB Headset.  I am unable to set the USB Headset as the primary audio device.  It is listed in the pull down to change the audio device, but when I exit the application, the on-board is still the default.

Version-Release number of selected component (if applicable):
system-config-soundcard-1.2.10-3

How reproducible:
Always

Steps to Reproduce:
1.  On a machine that has an onboard audio card(AC97), add a USB headset.
2.  Run the soundcard-detection program
3.  Set the default audio device to the USB headset.
4.  Play something music like.
  

Actual Results:  When you play a song or some kind of music, the output will still stay on the on-bpard audio device.  In addition, if you re-run the soundcard-detection application, the on-board will be the default again.  

Expected Results:  Audio should come out the USB headset, if the application is using ALSA.  Also, the soundcard-detection application should reflect that the default audio device is the USB headset, not the on-board AC97 device.

Additional info:

I am running FC4T1 on a Dell Latitude D800.  The USB headset(which works just fine BTW), is a Plantronics DSP 300.


/etc/modprobe.conf looks like this:

alias eth0 tg3
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0install snd-usb-audio /sbin/modprobe --ignore-install snd-usb-audio && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
alias ieee1394-controller ohci1394

Comment 1 Need Real Name 2005-04-08 21:14:33 UTC
This is a "not saving sound settings" bug, so possibly a dupe of bug 132575.

Comment 2 Mary Ellen Foster 2005-04-08 21:22:31 UTC
FWIW, the same weirdness happens with an external USB sound card (Soundblaster
MP3+) combined with an AC97 internal card.

Comment 3 Sean Bruno 2005-04-08 21:53:22 UTC
I am not savvy enough to determine if this is a duplicate of 132575.  However,
that one references volume settings which appear to be fine on both devices for
my machine.

I am more interested in the the changing of the default sound device, which
definitely is not a duplicate issue.  Please let me know how this issue is
caused by the aforementioned bug.  I just don't see the issue that I am seeing
being described in 132575.

Comment 4 Bastien Nocera 2005-04-11 16:12:52 UTC

*** This bug has been marked as a duplicate of 134316 ***


Note You need to log in before you can comment on or make changes to this bug.