Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154260 - PyQt requires sip package
Summary: PyQt requires sip package
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: PyQt
Version: 3
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-08 19:48 UTC by Konstantin Korikov
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-25 15:01:10 UTC


Attachments (Terms of Use)

Description Konstantin Korikov 2005-04-08 19:48:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; ru-RU; rv:1.7.6) Gecko/20050318 Firefox/1.0.2

Description of problem:
Whe I try to import the qt module from a Python program and sip package is not
installed, I get exception:
Traceback (most recent call last):
  File "<string>", line 1, in ?
ImportError: No module named sip

Version-Release number of selected component (if applicable):
PyQt-3.13-1

How reproducible:
Always

Steps to Reproduce:
1.

   $ rpm -e sip

2.

   $ python -c 'import qt'

Actual Results:  Traceback (most recent call last):
  File "<string>", line 1, in ?
ImportError: No module named sip


Expected Results:  error: Failed dependencies:
        sip is needed by (installed) PyQt-3.13-1


Additional info:

Comment 1 Dan Allen 2005-04-22 21:18:05 UTC
I was here to report this exact problem.  The point I want to add is running

yum install PyQt

does not bring along the sip package.  I would expect that yum would pick up on
this dependency and also install the sip rpm.

The keyword should be set to "EasyFix" as this is a dependency problem in the
rpm spec.

Comment 2 Dan Allen 2005-04-22 21:24:03 UTC
Add the following as line 36 of the PyQt.spec file

Requires: sip >= %{sip_version}

Comment 3 Ngo Than 2005-04-25 15:01:10 UTC
it's fixed in rawhide (PyQt-3.13-3)


Note You need to log in before you can comment on or make changes to this bug.