Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154250 - cannot upgrade from RHEL4 gold; blocked by gcc?
Summary: cannot upgrade from RHEL4 gold; blocked by gcc?
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date
Version: 4.0
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Pradeep Kilambi
QA Contact: Ken Reilly
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-08 18:41 UTC by Zack Cerza
Modified: 2013-02-27 00:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-23 16:48:18 UTC


Attachments (Terms of Use)
output of 'up2date -u' (deleted)
2005-04-08 18:41 UTC, Zack Cerza
no flags Details

Description Zack Cerza 2005-04-08 18:41:11 UTC
Description of problem:
After installing RHEL4 Desktop, up2date -u fails.

Version-Release number of selected component (if applicable):
up2date-4.4.5-1.x86_64

How reproducible:
Always

Steps to Reproduce:
1. up2date -u
  
Actual results:
Test install failed because of package conflicts:
package gcc-3.4.3-9.EL4 is already installed

Expected results:
Success.

Additional info:
See attached log.

Comment 1 Zack Cerza 2005-04-08 18:41:12 UTC
Created attachment 112870 [details]
output of 'up2date -u'

Comment 2 Suzanne Hillman 2005-04-11 15:43:40 UTC
Zack, is this a multilib thing?

Comment 3 Zack Cerza 2005-04-11 21:59:13 UTC
I don't think so.

% rpm -qa | grep -i gcc | grep i386
compat-libgcc-296-2.96-132.7.2.i386

up2date is just incorrectly trying to update gcc, when the newest version is
already installed.

Comment 4 Suzanne Hillman 2005-04-12 18:10:24 UTC
No... I'm asking because in your attachment:

gcc                                     3.4.3          9.EL4             x86_64

Is the version of gcc that's already on the machine i386, or x86_64?

Comment 5 Zack Cerza 2005-04-12 18:27:20 UTC
Uh, It's x86_64. If it were i386, the rpm/grep line I pasted would have said  
so. ;P

Comment 6 Suzanne Hillman 2005-04-12 19:21:34 UTC
Oh, I see. Spacy, me. Yes. :)

Comment 7 Zack Cerza 2005-05-20 14:43:19 UTC
Ping? This is still an issue...

Comment 11 RHEL Product and Program Management 2010-04-23 16:48:18 UTC
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.


Note You need to log in before you can comment on or make changes to this bug.