Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154246 - kbuildsycoca crashes with signal 11 on kde startup
Summary: kbuildsycoca crashes with signal 11 on kde startup
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdelibs
Version: rawhide
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-08 18:13 UTC by Mickey Stein
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-13 13:12:11 UTC


Attachments (Terms of Use)
This was the kbuildsycoca dump from the popup during kde startup. (deleted)
2005-04-08 18:15 UTC, Mickey Stein
no flags Details
As asked for "applications.menu". (deleted)
2005-04-08 19:56 UTC, Mickey Stein
no flags Details

Description Mickey Stein 2005-04-08 18:13:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041109 Firefox/1.0

Description of problem:
I use $startx to start kde from init level 3 on the latest rawhide. After today's updates, (I suspect kdelibs in particular), kde starts, but when parsing the first few of it's components on the splashscreen, a 'crash popup' shows behind the splash which is a dump of kbuildsycoca. The dump will be attached.

I tried this two ways: 

  1) As a new user with no $HOME/.kde directory
      - This crashed many times rather than once, and couldn't complete kde 
        startup.

  2) As an old user with a .kde dir that was working fine before today's updates. 
      - This crashed once, and after I saved and closed the crash popup, 
        kde 'appears' to run ok.

---- Kbuildsycoca crash popup contents ------

I'll submit as attachment after the initial report.


Mickey

Version-Release number of selected component (if applicable):
kdelibs-3.4.0-3

How reproducible:
Always

Steps to Reproduce:
1. Install kdelibs-3.4.0-3 from 08Apr05 rawhide
2. start kde using /usr/bin/startx from lvl 3 with or without a .kde directory.
3. note any kbuildsycoca popups/crashes 
4. 
  

Actual Results:  Kde either crashed if no .kde directory with multiple popups, or if .kde exists and was ok before, then only a single kbuildsycoca popup appeared but kde functioned.

Expected Results:  Normal kde startup, no popups, no crashes.

Additional info:

My system:

1) All rawhide up to 08Apr05.
2) Latest -Bk kernel (2.6.12-bk2)

Comment 1 Mickey Stein 2005-04-08 18:15:48 UTC
Created attachment 112868 [details]
This was the kbuildsycoca dump from the popup during kde startup.

If you're starting kde without a .kde directory, then you'll get a large number
of these dumps. All appear to be similar, but are happening on various events.

Comment 2 Mickey Stein 2005-04-08 18:40:45 UTC
And finally: It took me awhile to find the prior version of kdelibs to test
reversion. The result was this:

Reverted to kdelibs-3.4.0-2, (and -devel) and the kbuildsycoca dumps are gone in
both .kde and non .kde directories. It works fine.

I was also concerned that I'd recently installed glibc without restarting kde,
but this seems to be a kdelibs situation.

Comment 3 Ngo Than 2005-04-08 19:14:48 UTC
could you please attach the /etc/xdg/menus/applications.menu.

does it work if you just remove the file /etc/xdg/menus/kde-applications.menu?

Thanks
 

Comment 4 Mickey Stein 2005-04-08 19:56:58 UTC
Created attachment 112873 [details]
As asked for "applications.menu". 

Removing it didn't cause the problem to go away. Is there a -debuginfo for that
version of kdelibs? If not, I suppose I can try a rpmbuild from the .src.rpm
and use that. I know my crash-log isn't too informative without symbols.
Thanks.

Comment 5 Sammy 2005-04-08 20:19:44 UTC
I can confirm the same crash with -3 version. 

Comment 6 Ngo Than 2005-04-08 21:38:45 UTC
it's strange, are you sure that you have removed the
/etc/xdg/menus/kde-applications.menu?

it works for me after removing this file!

Comment 7 Ngo Than 2005-04-08 21:41:49 UTC
if you overwrite /etc/xdg/menus/kde-applications.menu with
/etc/xdg/menus/applications.menu, does it still crash ?

cp -f /etc/xdg/menus/applications.menu /etc/xdg/menus/kde-applications.menu

Comment 8 Mickey Stein 2005-04-08 22:51:56 UTC
My mistake ;) :: 

I'd made a backup xdg directory and removed it from there somehow. Yes, it works
fine if I get rid of that file. Thanks.

Meanwhile, I'm building the -debug*.rpm for kdelibs from source. If there's any
other tests you'd like me to run, just say the word.



Comment 9 Ngo Than 2005-04-09 10:08:40 UTC
please don't use the kdelibs-3.4.0-3 in the rawhide, it's broken because of new
gcc-4.0.0-0.40, which miscompiled kde/qt :(

for more infos #154294

Comment 10 Ngo Than 2005-04-13 13:12:11 UTC
it's already fixed in kdelibs-3.4.0-4, which is available in rawhide.


Note You need to log in before you can comment on or make changes to this bug.