Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154241 - nfsd: nfsv4 idmapping failing: has idmapd not been started?
Summary: nfsd: nfsv4 idmapping failing: has idmapd not been started?
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: nfs-utils
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-08 17:55 UTC by Orion Poplawski
Modified: 2009-03-14 06:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-06 11:43:55 UTC


Attachments (Terms of Use)

Description Orion Poplawski 2005-04-08 17:55:09 UTC
Description of problem:

I'm see this error in my logs.  I'm running nfs-utils from rawhide (rebuilt on
FC3) to fix another nfsv4 issue.  idmapd is running.

alexandria: Apr  5 14:58:02 alexandria kernel: nfsd: nfsv4 idmapping failing:
has idmapd not been started?
alexandria: Apr  7 03:54:43 alexandria kernel: nfsd: nfsv4 idmapping failing:
has idmapd not been started?
alexandria: Apr  8 08:56:40 alexandria kernel: nfsd: nfsv4 idmapping failing:
has idmapd not been started?
alexandria: Apr  8 10:38:59 alexandria kernel: nfsd: nfsv4 idmapping failing:
has idmapd not been started?
alexandria: Apr  8 10:39:05 alexandria kernel: nfsd: nfsv4 idmapping failing:
has idmapd not been started?

Version-Release number of selected component (if applicable):
nfs-utils-1.0.7-1

How reproducible:
Haven't tried triggering it.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Clint Goudie 2005-06-17 19:16:49 UTC
I'm also seeing this on a newly built and up2dated FC4 box

Comment 2 Clint Goudie 2005-06-17 19:18:24 UTC
from /var/log/messages
Jun 17 13:15:17 lenny kernel: nfsd: nfsv4 idmapping failing: has idmapd not been
started?

service rpcidmapd status
rpc.idmapd (pid 1516) is running...


Comment 3 Clint Goudie 2005-06-17 19:31:39 UTC
Sorry for the chain of messages. I'm also seeing this on startup:

Jun 17 13:19:51 lenny rpc.idmapd: nfsdreopen: Opening '' failed: errno 2 (No
such file or directory)

I suspect that this message is the root cause of this error...

my /etc/exports looks like 

/usr/local/somedir           *(rw,async,fsid=0,no_subtree_check)

Comment 4 Charles Lopes 2005-10-03 09:25:56 UTC
With the last rawhide build, I'm still seeing the first message here described.
Recently a post on the nfs4 mailing list has provided a fix to this problem. I
have recompiled nfs-utils-1.0.7-18.FC5 with this patch applied and it seems to
fix the problem. Here's the URL to the post with the patch:

http://linux-nfs.org/pipermail/nfsv4/2005-September/002615.html

Could you please consider adding it to the next nfs-utils build?
Thanks in advance.


Comment 5 David Abrahams 2009-03-14 06:10:55 UTC
The workaround described here seems to handle the problem: https://bugs.launchpad.net/ubuntu/+source/nfs-utils/+bug/87382/comments/14


Note You need to log in before you can comment on or make changes to this bug.