Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154203 - perl-DBD-Pg: update and specfile cleanup
Summary: perl-DBD-Pg: update and specfile cleanup
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-DBD-Pg
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-08 11:59 UTC by Jose Pedro Oliveira
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-14 04:50:53 UTC


Attachments (Terms of Use)
Update and specfile cleanup. (deleted)
2005-04-08 18:36 UTC, Jose Pedro Oliveira
no flags Details | Diff
Update and specfile cleanup (now in unified output format) (deleted)
2005-04-13 23:46 UTC, Jose Pedro Oliveira
no flags Details | Diff

Description Jose Pedro Oliveira 2005-04-08 11:59:47 UTC
Version-Release number of selected component (if applicable):
1.40-1

Expected results:
1.41-1

Comment 1 Warren Togami 2005-04-08 18:32:46 UTC
patch?

Comment 2 Jose Pedro Oliveira 2005-04-08 18:36:24 UTC
Created attachment 112869 [details]
Update and specfile cleanup.

Sorry!

Comment 3 Jose Pedro Oliveira 2005-04-08 19:42:17 UTC
Warren,

The test suite of DBD::Pg versions 1.40 and 1.41 fails 4 tests
(at least in FC3).  No problems are reported by the DBD::Pg versions 1.31
and 1.32 test suites.

Created a ticket describing the problem in rt.cpan.org [cpan #12204]
(https://rt.cpan.org/NoAuth/Bug.html?id=12204).

jpo

Comment 4 Warren Togami 2005-04-08 20:52:12 UTC
Do you recommend we upgrading this and disabling the test, or wait?


Comment 5 Jose Pedro Oliveira 2005-04-09 01:28:55 UTC
Let's postpone the upgrade for a couple of days to see if I have feedback from the
DBD::Pg maintainers.

Comment 6 Jose Pedro Oliveira 2005-04-13 17:28:42 UTC
Warren,

Good news:
- the error described in comment #3 is harmless.  It was caused by a mismatch
  between DBD-Pg and DBI versions.  The test file has been corrected upstream.
  (see the CPAN rt ticket).
 
Bad news:
- the perl-DBD-Pg test suite fails with a different error in a FC4test2
  system (postgresql v8).  I will try to look into it.

Comment 7 Jose Pedro Oliveira 2005-04-13 23:46:47 UTC
Created attachment 113134 [details]
Update and specfile cleanup (now in unified output format)

Comment 8 Warren Togami 2005-04-14 00:24:21 UTC
Do you want to go ahead with this, or wait?


Comment 9 Jose Pedro Oliveira 2005-04-14 00:46:50 UTC
Go ahead.

It appears to be more problems in the test code. Just in case I will report the
new error upstream.

Comment 10 Warren Togami 2005-04-14 04:50:53 UTC
Why README.win32? =)


Note You need to log in before you can comment on or make changes to this bug.