Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154198 - r8169 can't force full duplex
Summary: r8169 can't force full duplex
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: ethtool
Version: 3
Hardware: athlon
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jeff Garzik
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-08 10:12 UTC by Jacques
Modified: 2013-07-03 02:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-13 08:35:12 UTC


Attachments (Terms of Use)

Description Jacques 2005-04-08 10:12:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
I am trying to force my network card into full duplex mode (RealTek 8169 on a Gigabyte GA-7N400 PRO2 m/board). I have downloaded and compiled ethtool-3.

# ./ethtool eth0
Settings for eth0:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Full 
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Full 
        Advertised auto-negotiation: Yes
        Speed: 100Mb/s
        Duplex: Half
        Port: Twisted Pair
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Link detected: yes

# ./ethtool -s eth0 autoneg off speed 100 duplex full

# ./ethtool eth0
Settings for eth0:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Full 
        Supports auto-negotiation: Yes
        Advertised link modes:  100baseT/Half 100baseT/Full 
        Advertised auto-negotiation: Yes
        Speed: 100Mb/s
        Duplex: Half
        Port: Twisted Pair
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Link detected: yes


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run ./ethtool -s eth0 autoneg off speed 100 duplex full


Actual Results:  The network card remained at Half-Duplex.

Expected Results:  Should have switched to full duplex.

Additional info:

kernel kernel-2.6.10-1.770_FC3
# modinfo r8169
filename:       /lib/modules/2.6.10-1.770_FC3/kernel/drivers/net/r8169.ko
author:         Realtek
description:    RealTek RTL-8169 Gigabit Ethernet driver
parm:           use_dac:Enable PCI DAC. Unsafe on 32 bit PCI slot.
license:        GPL
vermagic:       2.6.10-1.770_FC3 686 REGPARM 4KSTACKS gcc-3.4
depends:        
alias:          pci:v000010ECd00008169sv*sd*bc*sc*i*
alias:          pci:v00001186d00004300sv*sd*bc*sc*i*
srcversion:     539B8B1491690B9C172B96B

# lspci -v (relevant part of)
01:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)
        Subsystem: Giga-byte Technology GA-K8VT800 Pro Motherboard
        Flags: bus master, 66Mhz, medium devsel, latency 64, IRQ 9
        I/O ports at 9400 [size=256]
        Memory at ec006000 (32-bit, non-prefetchable) [size=256]
        Capabilities: [dc] Power Management version 2

Comment 1 Jacques 2005-04-13 08:35:12 UTC
Humblest apologies. This error turned out to be due to a (intermittently) faulty
switch.


Note You need to log in before you can comment on or make changes to this bug.