Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154196 - UTF-8 locales: deadlock and GUI issues
Summary: UTF-8 locales: deadlock and GUI issues
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: mc
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-08 09:09 UTC by wwp
Modified: 2013-07-02 23:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-08 17:26:59 UTC


Attachments (Terms of Use)

Description wwp 2005-04-08 09:15:45 UTC
I got a 500 internal server error when created this bug, and since I cannot find
the error description on this page, here is the detail, sorry if this is redundant:

With FC3's mc-4.6.1-0.12.FC and mc-4.6.1a-0.8, with default locale settings
(en_US.UTF-8), I'm facing two issues around files that contain accented chars.

With mc-4.6.1-pre3 or 4.6.1-pre4 (which correspond to the mc version the FC3's
packages are based on), I don't encounter such problems.

1. start mc, get bad stickchars (window and dialog frames), until -a is used.

2. other problem: when I copy files or try to view files that contains accented
chars, mc freezes until I kill it (well I did not find any way to unfreeze it).
For instance, pressing F3 over the following filename locks mc (as well as
trying to copy it): /tmp/confirmation_résa_hotel.rtf (it shows a '?' instead of
the 'é' in the file list).


Comment 1 Jindrich Novy 2005-04-08 11:21:42 UTC
wwp, thanks for reporting this. This bug is maybe somehow related to bug 150569.
mc-4.6.1a-0.5 and any later version contains fix for that issue, could you
please check whether its fixed in this version?

You can get the rpms/srpms from:
http://people.redhat.com/jnovy/files/

I checked it on the file named confirmation_résa_hotel.rtf and it seems to be fixed.

In the case related to frames all works fine for me - I don't need to disable
the graphic characters for line drawing. This is possibly caused by some bad
terminal settings. Do you see similar problems with frame drawing also in elinks
for instance?


Comment 2 wwp 2005-04-08 11:48:35 UTC
Sorry Jindrich, I had already tested this version (see my former message), the
problems persist with that mc-4.6.1a-0.8.


Comment 3 Jindrich Novy 2005-04-08 12:28:03 UTC
Ah, missed that in your original message. What terminal do you use? All things
work just fine for me with gnome-terminal and xterm, are you able to reproduce
it also on some other FC3 machine? How are the frames displayed when you don't
use the '-a' option? (the best solution would be to attach here a screenshot via
Create a New Attachment on bottom on this page)

We need to let me reproduce the problem otherwise I have no way to do and test a
fix for that.

Comment 4 wwp 2005-04-08 13:41:35 UTC
Ah-ah you're right, definitely. With gnome-terminal and native xterm, mc
0.4.1a-0.8 behaves correctly. I'm using mrxvt 0.3.12 (materm.sf.net) w/ some
parameters that break the things (mrxvt w/ no param is OK).
Sorry for the noise guys, I'll see that w/ mrxvt's author if I did not use it in
a wrong way.. Thanks for your help!


Comment 5 Jindrich Novy 2005-04-08 17:26:59 UTC
Ok, thanks for the feedback anyway. Without feedback I suppose that mc works
just fine. In case you find some issue please don't hesitate to file another bug :)

Thanks,
Jindrich

Comment 6 wwp 2005-04-08 21:33:30 UTC
Sorry for the noise.. I should have thought about possible issues coming from
the term type.. Thanks for your prompt help!



Note You need to log in before you can comment on or make changes to this bug.