Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154195 - httpd won't start.. complains about not being able to access libphp5.so
Summary: httpd won't start.. complains about not being able to access libphp5.so
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: php
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
: 155321 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-08 08:31 UTC by Kyle Pointer
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 5.0.4-3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-11 13:06:57 UTC


Attachments (Terms of Use)

Description Kyle Pointer 2005-04-08 08:31:07 UTC
Description of problem:
httpd will not start.. :(


Version-Release number of selected component (if applicable):
Apache/2.0.53
PHP 5.0.4 (cgi)

How reproducible:
Not sure how this happened. 
Everything worked fine, then I setup wordpress and it worked fine but for some
reason when I rebooted httpd complains about not having permissions to libphp5.so...
wich this message.

[root@fluffbox ~]# httpd
Syntax error on line 6 of /etc/httpd/conf.d/php.conf:
Cannot load /etc/httpd/modules/libphp5.so into server:
/etc/httpd/modules/libphp5.so: cannot restore segment prot after reloc:
Permission denied
[root@fluffbox ~]# /etc/httpd/modules/libphp5.so
Segmentation fault

Comment 1 Joe Orton 2005-04-11 13:06:57 UTC
Sorry this made it into the test release.  Fixed in Raw Hide; it should work
also if you disable SELinux.

Comment 2 Kyle Pointer 2005-04-11 20:51:28 UTC
:0) Yeah I got it figured out, but I forgot to close the bug. Sorry. 
But thats how I fixed it and it works now. But one other question. 
Is it just me or do the buttons in the system-config-security to specify
trusting services like FTP and HTTP ( specificly FTP ) not allow all of the
right ports? 
Because what will happen is, I will try to enable FTP with that diolog but it
still doesn't work until I make eth0 a trusted device. :(

Comment 3 Joe Orton 2005-04-11 20:57:17 UTC
It's a real bug, you were exactly right to file it - thanks.  As to other bugs,
try filing new ones, or ask on fedora-test-list@redhat.com if you're unsure.

Comment 4 Joe Orton 2005-04-19 07:32:45 UTC
*** Bug 155321 has been marked as a duplicate of this bug. ***

Comment 5 Joe Orton 2005-04-19 07:49:37 UTC
*** Bug 155321 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.