Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154194 - ClassNotFound exception on eclipse startup
Summary: ClassNotFound exception on eclipse startup
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ben Konrath
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-08 08:14 UTC by jeroen
Modified: 2008-08-02 23:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-10-05 20:05:39 UTC


Attachments (Terms of Use)

Description jeroen 2005-04-08 08:14:28 UTC
!SESSION 2005-04-08 10:11:22.948 -----------------------------------------------
eclipse.buildId=I20050219-1500
java.fullversion=GNU libgcj 4.0.0 20050405 (Red Hat 4.0.0-0.40)
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments:  -os linux -ws gtk -arch x86_64 -data /home/jeroen/workspace

!ENTRY org.eclipse.osgi 2005-04-08 10:11:22.948
!MESSAGE Application error
!STACK 1
java.lang.NoClassDefFoundError: while resolving class: org.eclipse.swt.graphics.GC
   at java.lang.VMClassLoader.transformException(java.lang.Class,
java.lang.Throwable) (/usr/lib64/libgcj.so.6.0.0)
   at java.lang.VMClassLoader.resolveClass(java.lang.Class)
(/usr/lib64/libgcj.so.6.0.0)
   at java.lang.Class.initializeClass() (/usr/lib64/libgcj.so.6.0.0)
   at org.eclipse.swt.widgets.CoolItem.createArrowImage(int, int) (Unknown Source)
   at org.eclipse.swt.widgets.CoolItem.updateChevron() (Unknown Source)
   at org.eclipse.swt.widgets.CoolItem.setBounds(int, int, int, int) (Unknown
Source)
   at org.eclipse.swt.widgets.CoolBar.layoutItems() (Unknown Source)
   at org.eclipse.swt.widgets.CoolBar.relayout() (Unknown Source)
   at org.eclipse.swt.widgets.CoolItem.setSize(int, int) (Unknown Source)
   at org.eclipse.swt.widgets.CoolItem.setSize(org.eclipse.swt.graphics.Point)
(Unknown Source)
   at org.eclipse.jface.action.ToolBarContributionItem.updateSize(boolean)
(Unknown Source)
   at
org.eclipse.jface.action.ToolBarContributionItem.fill(org.eclipse.swt.widgets.CoolBar,
int) (Unknown Source)
   at org.eclipse.jface.action.CoolBarManager.update(boolean) (Unknown Source)
   at
org.eclipse.jface.action.CoolBarManager.createControl(org.eclipse.swt.widgets.Composite)
(Unknown Source)
   at
org.eclipse.jface.window.ApplicationWindow.createCoolBarControl(org.eclipse.swt.widgets.Composite)
(Unknown Source)
   at
org.eclipse.ui.internal.WorkbenchWindow.createDefaultContents(org.eclipse.swt.widgets.Shell)
(Unknown Source)
   at
org.eclipse.ui.internal.WorkbenchWindowConfigurer.createDefaultContents(org.eclipse.swt.widgets.Shell)
(Unknown Source)
   at
org.eclipse.ui.application.WorkbenchWindowAdvisor.createWindowContents(org.eclipse.swt.widgets.Shell)
(Unknown Source)
   at
org.eclipse.ui.internal.WorkbenchWindow.createContents(org.eclipse.swt.widgets.Composite)
(Unknown Source)
   at org.eclipse.jface.window.Window.create() (Unknown Source)
Caused by: java.lang.ClassNotFoundException:
org.eclipse.swt.internal.cairo.cairo_font_extents_t
   at
org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(java.lang.String)
(Unknown Source)
   at
org.eclipse.osgi.framework.adaptor.core.AbstractClassLoader.loadClass(java.lang.String,
boolean) (Unknown Source)
   at java.lang.Class.forName(java.lang.String, boolean, java.lang.ClassLoader)
(/usr/lib64/libgcj.so.6.0.0)
   at java.lang.VMClassLoader.resolveClass(java.lang.Class)
(/usr/lib64/libgcj.so.6.0.0)
   at java.lang.Class.initializeClass() (/usr/lib64/libgcj.so.6.0.0)
   at org.eclipse.swt.widgets.CoolItem.createArrowImage(int, int) (Unknown Source)
   at org.eclipse.swt.widgets.CoolItem.updateChevron() (Unknown Source)
   at org.eclipse.swt.widgets.CoolItem.setBounds(int, int, int, int) (Unknown
Source)
   at org.eclipse.swt.widgets.CoolBar.layoutItems() (Unknown Source)
   at org.eclipse.swt.widgets.CoolBar.relayout() (Unknown Source)
   at org.eclipse.swt.widgets.CoolItem.setSize(int, int) (Unknown Source)
   at org.eclipse.swt.widgets.CoolItem.setSize(org.eclipse.swt.graphics.Point)
(Unknown Source)
   at org.eclipse.jface.action.ToolBarContributionItem.updateSize(boolean)
(Unknown Source)
   at
org.eclipse.jface.action.ToolBarContributionItem.fill(org.eclipse.swt.widgets.CoolBar,
int) (Unknown Source)
   at org.eclipse.jface.action.CoolBarManager.update(boolean) (Unknown Source)
   at
org.eclipse.jface.action.CoolBarManager.createControl(org.eclipse.swt.widgets.Composite)
(Unknown Source)
   at
org.eclipse.jface.window.ApplicationWindow.createCoolBarControl(org.eclipse.swt.widgets.Composite)
(Unknown Source)
   at
org.eclipse.ui.internal.WorkbenchWindow.createDefaultContents(org.eclipse.swt.widgets.Shell)
(Unknown Source)
   at
org.eclipse.ui.internal.WorkbenchWindowConfigurer.createDefaultContents(org.eclipse.swt.widgets.Shell)
(Unknown Source)

This is with packages from fc-devel from today (april 8).

Comment 1 Andrew Overholt 2005-04-08 18:03:09 UTC
Updating architecture.

In the future, could you please attach the stack trace instead of pasting it in
'cause bugzilla's text-wrapping makes them hard to read.  :)

Comment 2 Andrew Overholt 2005-04-19 20:49:12 UTC
Ben tried to duplicate these x86_64 issues with our latest RPMs.  Can you see if
this is fixed with the versions below?

from bug 152345:

I just tested the latest stuff from rawhide on x86_64 and they seem to work. Can
someone confirm this with a clean workspace and config directory?

% rpm -qa | grep java
java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp_18rh
gcc-java-4.0.0-0.42
java-1.4.2-gcj-compat-1.4.2.0-40jpp_18rh
java-1.4.2-gcj-compat-src-1.4.2.0-40jpp_18rh

% rpm -qa | grep eclipse
eclipse-platform-3.1.0_fc-0.M6.6
eclipse-ecj-3.1.0_fc-0.M6.6
eclipse-jdt-3.1.0_fc-0.M6.6
eclipse-pde-3.1.0_fc-0.M6.6
eclipse-platform-devel-3.1.0_fc-0.M6.6

Comment 3 Dave Atkinson 2005-06-29 14:29:12 UTC
Jeroen, Is this a manifestation of
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=156005
?
I had a similar problem, not just with eclipse, but all java programs trying to
open a gui.  Can you run any java programs, and does the fix suggested in the
bug report above work for you?

Comment 4 Andrew Overholt 2005-09-13 14:32:05 UTC
Any news here?

Comment 5 Christopher Stone 2006-02-05 05:20:13 UTC
I tried installing those rawhide RPMs in FC4, it's a no go, no way to test it
unless you do a full system upgrade to rawhide.

Comment 6 Andrew Overholt 2006-10-05 20:05:39 UTC
This bug is against FC4 which is no longer supported.  Please re-test with FC5/6
and re-open if it's still happening.  Thanks.


Note You need to log in before you can comment on or make changes to this bug.