Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154172 - when ddcprobe fails, s-c-display always sets SVGA hsync & vsync
Summary: when ddcprobe fails, s-c-display always sets SVGA hsync & vsync
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rhpxl
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-07 22:25 UTC by Maxim Dziumanenko
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-12-02 16:21:16 UTC


Attachments (Terms of Use)
patch getting monitor refresh from MonitorsDB for known monitor (deleted)
2005-04-07 22:25 UTC, Maxim Dziumanenko
no flags Details | Diff

Description Maxim Dziumanenko 2005-04-07 22:25:15 UTC
Description of problem:
I have Dell Latitude CPx J650GT and configured LCD Panel 1024x768 in anaconda.
When I starting system-config-display, ddcprobe fails and rhpl.xhwstate sets
monitor refresh at hsync=31.5-37.9 vsync=50-70. Because of this I have only two
choices for display resolution: 640x480 and 800x600, regardless of xorg.conf
configured to 1024x768. 

If I select "LCD Panel 1024x768" in "Monitor" dialod and press OK, then
"Resolution" combobox allows me to select 1024x768. But this choice disappears
when I restarting system-config-display again.

IMO it such cases (if ddcprobe fails and xorg.xonf doesn't specify HorizSync and
VertRefresh explicitly) it would be better to get monitor`s hsync and vsync from
MonitorsDB, rather than set SVGA refresh values.

Version-Release number of selected component (if applicable):
rhpl-0.158

How reproducible:
Always

Steps to Reproduce:
1.Connect monitor that doesn`t work with ddcprobe but supports 1024x768
2.Run system-config-display
3.Try to set 1024x768 mode
  
Actual results:
There are no choice for 1024x768

Expected results:
1024x768 option in Resolution combobox

Additional info:

Comment 1 Maxim Dziumanenko 2005-04-07 22:25:16 UTC
Created attachment 112839 [details]
patch getting monitor refresh from MonitorsDB for known monitor

Comment 2 Chris Lumens 2005-12-02 16:21:16 UTC
Thanks for the patch.  Applied.


Note You need to log in before you can comment on or make changes to this bug.