Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154161 - Missing color profile support with lcms
Summary: Missing color profile support with lcms
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: ImageMagick
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-07 22:08 UTC by Dr. Tilmann Bubeck
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-21 20:26:55 UTC


Attachments (Terms of Use)
Patch to fix the problem (deleted)
2005-04-07 22:09 UTC, Dr. Tilmann Bubeck
no flags Details | Diff

Description Dr. Tilmann Bubeck 2005-04-07 22:08:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040922

Description of problem:
ImageMagick is able to deal with color-profiles (command line option -profile). But unfortunately the lcms-devel (from FC extras) was missing, so the IM was built without lcms support.

This is important for CMYK color conversion.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. convert -profile XXX.icc a.gif a.png
  

Actual Results:  Error message missing LCMS support.


Expected Results:  Conversion with color profiles

Additional info:

Comment 1 Dr. Tilmann Bubeck 2005-04-07 22:09:58 UTC
Created attachment 112838 [details]
Patch to fix the problem

The attached patch fixed the problem by changing the spec file to include a
BuildReq.

Comment 2 Matthias Clasen 2005-04-21 20:26:55 UTC
ImageMagick is in FC, and thus cannot be linked against a library in FE. 
It is actually a bit dubious that lcms is in FE, due to possible patent issues


Note You need to log in before you can comment on or make changes to this bug.