Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154155 (blockerbugsearch) - Need a way to search for empty BugsDependingOnThisBug fields
Summary: Need a way to search for empty BugsDependingOnThisBug fields
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: blockerbugsearch
Product: Bugzilla
Classification: Community
Component: Bugzilla General
Version: 2.18
Hardware: All
OS: Linux
high
high vote
Target Milestone: ---
Assignee: PnT DevOps Devs
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-07 21:22 UTC by Rich Megginson
Modified: 2013-06-24 03:00 UTC (History)
1 user (show)

Fixed In Version: 2.18
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-18 17:28:04 UTC


Attachments (Terms of Use)

Description Rich Megginson 2005-04-07 21:22:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2) Gecko/20040805 Netscape/7.2

Description of problem:
We are using tracking/blocker bugs for our product.  However, we think some of the bugs may not have been created or modified to block our blocker/tracking bug.  There is currently no way to search for these bugs that I can find.  The boolean charts work correctly for bugs that have the BugsDependingOnThisBug filled in with some value, but not for bugs that have that field empty.  Can we have an "is empty" boolean chart added that would look for BugsDependingOnThisBug == nil or something like that?  Another alternative that would help us would be to have some way to Change Columns to have the BugsDependingOnThisBug column listed.  Then we could at least visually scan the list to see if there are any empty ones.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Try to do a search to list bugs that have an empty BugsDependingOnThisBug field.
2.
3.
  

Actual Results:  Zarro Boogs.

Expected Results:  A list of bugs which do not block other bugs.

Additional info:

The severity is High because we are approaching a release date and must know if all of our bugs have been tracked.  If this isn't fixed, we have no choice but to go through all of the bugs by hand, a daunting and error prone task.

Comment 1 Rich Megginson 2007-10-18 17:14:52 UTC
Hello - anyone there?  This bug has been open for about 2 1/2 years.  If it is
simply not possible to do this, and there are no plans to support this, can we
just file this bug as WONTFIX and be done with it?

Comment 2 David Lawrence 2007-10-18 17:28:04 UTC
Sorry for the long delay. It fell off our radars unfortunately.

You can choose from the boolean charts section on the Advanced Query page "is
null" or "is not null" in the middle drop down. This should give you the query
you are looking for.

Also you can now see the BlockedBy and DependsOn values in the bug query results
by clicking on "Change Columns" at the bottom of the list. You can then select the
two extra columns and resubmit your last query.

Please reopen this if you have any difficulties.

Dave 


Note You need to log in before you can comment on or make changes to this bug.