Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154149 - anaconda.cfg contains bad password after manual install ("url --url ftp://user:%23%44%6D@site/")
Summary: anaconda.cfg contains bad password after manual install ("url --url ftp://use...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Mike McLean
URL:
Whiteboard: FC4
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-07 19:42 UTC by Frédéric Beuserie
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-13 20:36:52 UTC


Attachments (Terms of Use)
bad anaconda.cfg (deleted)
2005-04-07 19:44 UTC, Frédéric Beuserie
no flags Details

Description Frédéric Beuserie 2005-04-07 19:42:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
when netinstalling from a ftp site with username/password, 
the password is badly encoded into the final anaconda.cfg.

(it seems to be encoded with %XX for each ascii char)

simply remplacing with the correct password manually into ks resolve the problem.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. do a netinstall with ftp://username:password@site/
2. copy anaconda.cfg into the netinstall server
3. do a new netinstall with bootparam "linux ks=.../anaconda.ks"


  

Actual Results:  it fails to connect to the ftp server when retrieving rpm files


Expected Results:  connection should succeed with correct password.


Additional info:

ks is retrieved with anonymous http

Comment 1 Frédéric Beuserie 2005-04-07 19:44:52 UTC
Created attachment 112827 [details]
bad anaconda.cfg

the password as entered when manual install is "yum"

Comment 2 Chris Lumens 2005-04-13 20:36:52 UTC
Fixed in CVS - will appear in the next anaconda build after tomorrow's.


Note You need to log in before you can comment on or make changes to this bug.