Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154142 - xmlsec1 devel packages provide .la files with dangling references to /usr/lib/libxml2.la
Summary: xmlsec1 devel packages provide .la files with dangling references to /usr/lib...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xmlsec1
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-07 18:56 UTC by Nalin Dahyabhai
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 1.2.9-7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-06-08 13:40:45 UTC


Attachments (Terms of Use)

Description Nalin Dahyabhai 2005-04-07 18:56:12 UTC
Description of problem:
If your application uses libtool, you can't successfully link with libxmlsec1,
libxmlsec1-gnutls, or libxmlsec1-openssl.

Version-Release number of selected component (if applicable):
xmlsec1-devel-1.2.7-4
xmlsec1-gnutls-devel-1.2.7-4
xmlsec1-openssl-devel-1.2.7-4
libxml2-devel-2.6.19-1

How reproducible:
Always

Steps to Reproduce:
1. cat > foo.c << EOF
   int main(int argc, char **argv) { return 0; }
   EOF
2. libtool --mode=compile gcc -c -o foo.lo foo.c
3. libtool --mode=link    gcc -o foo foo.lo -lxmlsec1
  
Actual results:
libtool: link: cannot find the library `/usr/lib/libxml2.la'

Expected results:
No output, successful link.

Additional info:
This should fix itself if we just bump the release number and recompile the package.

Comment 1 Jeff Pitman 2005-10-01 04:09:23 UTC
php cannot compile without /usr/lib/libxml2.la  because it greps it when 
building modules, etc.  This cannot be seen without a completely distilled 
environment. 
 
My recommendation is to just package /usr/lib/libxml2.la with libxml2-devel. 
This in %files already does this: 
 
%{_libdir}/*a 
 
Just need to take away the "rm -f" completely. 

Comment 2 Daniel Veillard 2005-10-01 14:10:27 UTC
w.r.t. #2. No this is a policy decision, we won't packages .la anymore.

Daniel

Comment 3 Rex Dieter 2005-10-07 12:24:10 UTC
Nalin's suggestion is the right one.  Now that /usr/lib/libxml2.la is gone, all
packages that currently contain libtool archives themselves that include
references to (the now-missing) libxml2.la need to be rebuilt (and potentially
remove/omit their .la files as well). 

Comment 4 Rex Dieter 2005-10-21 15:48:12 UTC
If it wasn't clear from my comment #3, it appears that xmlsec1 simply needs to
be rebuilt.

Comment 5 Rex Dieter 2005-10-21 15:55:53 UTC
Though this bug is marked against -devel, it appears that it should be against
fc4, since xmlsec1-1.2.7-4 is the version from fc4.

Comment 6 Rex Dieter 2005-10-21 16:02:54 UTC
I just confirmed a rebuild is successful and fixes the problem (as originally
reported).

Future xmlsec1 builds (probably targeted at -devel/fc5) probably ought to not
include libtool archives (/usr/lib/lib*.la) or static libs (/usr/lib/lib*.a)
either, but that's a separate issue.



Comment 7 Rex Dieter 2005-10-21 16:05:40 UTC
FYI, see bug #171410: "remove *.la/*.a files"

Comment 8 Daniel Veillard 2006-06-08 13:40:45 UTC
Okay the extra .la should have been removed some time ago, but I forgot.
It should be fixed in rawhide, with the upcoming 1.2.9-7,

Daniel


Note You need to log in before you can comment on or make changes to this bug.