Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154140 - RHEL3 U5: On ICH7 system install in IDE mode changed to AHCI mode causes a Kernel Panic
Summary: RHEL3 U5: On ICH7 system install in IDE mode changed to AHCI mode causes a Ke...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel
Version: 3.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeff Garzik
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-07 18:52 UTC by Ed Ciechanowski
Modified: 2013-07-03 02:24 UTC (History)
5 users (show)

Fixed In Version: U5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-29 16:51:50 UTC


Attachments (Terms of Use)

Description Ed Ciechanowski 2005-04-07 18:52:22 UTC
Description of problem:
After installing RHEL3 U5 Beta release to a SATA drive with BIOS set to IDE. 
If you change the BIOS from IDE to AHCI mode, after reboot will cause a Kernel 
Panic. 

Version-Release number of selected component (if applicable):
2.4.21-31.EL

How reproducible:
Install RHEL3 U5 on an ICH7 system to an SATA drive with BIOS set to IDE mode. 
The installation will work correctly and you are able to login. Now reboot the 
system, enter the BIOS setup and change the SATA drive's mode from IDE mode to 
AHCI mode. When you save the setting and reboot you will get a Kernel Panic. 

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Kernel Panic when BIOS set to AHCI mode if it was installed in IDE mode. 

Expected results:
The OS should boot no matter what the BIOS is set to and the OS should load 
the correct driver.

Additional info:

Comment 1 Ed Ciechanowski 2005-04-07 18:53:42 UTC
Issue tracker 70145

Comment 2 Ed Ciechanowski 2005-08-29 16:51:50 UTC
This has been fixed and IT Closed on 5/2/2005. Closing this bug.

Comment 3 Ernie Petrides 2005-08-29 20:00:09 UTC
Hello, Ed.  According to a comment in IT 70145 dated 04-15-2005, this
bug reported a situation that is expected behavior.  Specifically,
there doesn't since to be any post-2.4.21-31.EL fix that went into U5
that could have addressed this.

Thus, I'm changing the disposition of this bug to CLOSED/WONTFIX.


Comment 4 Ernie Petrides 2005-08-29 20:12:43 UTC
Above comment should read "there doesn't seem to be ...".

Comment 5 Ed Ciechanowski 2005-08-30 15:51:41 UTC
Agreed.
Thanks for straightening this out.
*EDC*


Note You need to log in before you can comment on or make changes to this bug.