Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154139 - RHEL3 U5: On ICH7 system in AHCI mode, AHCI is not loading by default
Summary: RHEL3 U5: On ICH7 system in AHCI mode, AHCI is not loading by default
Keywords:
Status: CLOSED DUPLICATE of bug 154130
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel
Version: 3.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeff Garzik
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-07 18:39 UTC by Ed Ciechanowski
Modified: 2013-07-03 02:24 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-29 16:54:59 UTC


Attachments (Terms of Use)

Description Ed Ciechanowski 2005-04-07 18:39:59 UTC
Description of problem:
When installing RHEL3 U5 Beta release to an PATA drive with an additional SATA 
drive attached on a ICH7 system with the BIOS set to AHCI mode the 
installation will complete. After rebooting, logging in, and running lsmod you 
can see that the AHCI driver is not loaded by default and you are unable to 
see the SATA drive. After running Modprobe AHCI then the driver loads and the 
os will see the SATA drive.


Version-Release number of selected component (if applicable):
2.4.21-31.EL

How reproducible:
When installing RHEL3 U5 Beta release to an PATA drive with an additional SATA 
drive attached on a ICH7 system with the BIOS set to AHCI mode the 
installation will complete. After rebooting, logging in, and running lsmod you 
can see that the AHCI driver is not loaded by default and you are unable to 
see the SATA drive. After running Modprobe AHCI then the driver loads and the 
os will see the SATA drive.

or

After installing RHEL3 U5 Beta release to an PATA drive with an additional 
SATA drive attached on a ICH7 system with the BIOS set to IDE mode the 
installation will complete. Change the BIOS from IDE to AHCI. After rebooting, 
logging in, and running lsmod you can see that the AHCI driver is not loaded 
by default and you are unable to see the SATA drive. After running Modprobe 
AHCI then the driver loads and the os will see the SATA drive.


Steps to Reproduce:
1.
2.
3.
  
Actual results:
the AHCI driver is not loaded by default and you are unable to see the SATA 
drive

Expected results:
the AHCI driver is loaded by default and you are able to see the SATA drive.

Additional info:

Comment 1 Ed Ciechanowski 2005-04-07 18:41:29 UTC
Issue tracker#70144

Comment 2 Ed Ciechanowski 2005-08-29 16:54:59 UTC
IT was closed in RHEL3 U5 development cycle. Closing this Bug.

Comment 3 Ernie Petrides 2005-08-29 19:51:29 UTC

*** This bug has been marked as a duplicate of 154130 ***


Note You need to log in before you can comment on or make changes to this bug.