Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154132 - fails to find /dev/fd0 when started with ks=floppy
Summary: fails to find /dev/fd0 when started with ks=floppy
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-07 18:02 UTC by Nalin Dahyabhai
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-06-07 19:26:39 UTC


Attachments (Terms of Use)

Description Nalin Dahyabhai 2005-04-07 18:02:04 UTC
Description of problem:
When I boot Raw Hide 20050407 with ks=floppy, anaconda does an interactive
installation.

Version-Release number of selected component (if applicable):
Raw Hide 20050407, i386
anaconda -10.2.0.45-1

How reproducible:
Always

Steps to Reproduce:
1. Copy ks.cfg to a floppy disk
2. Put it into the drive
3. Boot with ks=floppy
  
Actual results:
Anaconda goes into interactive install mode.

Expected results:
Automated install.

Additional info:
On VT2, I can see these messages:
* doing kickstart from floppy
* no floppy devices
If I then proceed to stage2, when I get a shell on VT2, "ls /dev/fd*" prints
"ls: /dev/fd*: no such file or directory", but I can create the node by running
"mknod /dev/fd0" and then mount it successfully.

Comment 1 Nalin Dahyabhai 2005-04-07 18:20:56 UTC
Hmm, had an old util-linux-2.12pre-3 package on my box, so it wasn't current
(2.12p-5 is newer, even if RPM doesn't think so).

Comment 2 Nalin Dahyabhai 2005-04-07 18:21:45 UTC
Strike that last.  Wrong bug.

Comment 3 Chris Lumens 2006-03-29 16:46:57 UTC
What's the status of this in FC5?

Comment 4 Nalin Dahyabhai 2006-06-07 19:26:39 UTC
Hopefully it wasn't the specific box I was trying it on, because I can no longer
recall which one it was.  It seems to be working correctly in Raw Hide 20060607,
on the box I used today.  Closing with resolution RAWHIDE.  Thanks!


Note You need to log in before you can comment on or make changes to this bug.