Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154130 - RHEL3 U5: On ICH6 system in AHCI mode OS is loading the wrong driver
Summary: RHEL3 U5: On ICH6 system in AHCI mode OS is loading the wrong driver
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel
Version: 3.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeff Garzik
QA Contact: Brian Brock
URL:
Whiteboard:
: 154139 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-07 17:53 UTC by Ed Ciechanowski
Modified: 2013-07-03 02:24 UTC (History)
6 users (show)

Fixed In Version: RHEL3 U5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-29 16:56:52 UTC


Attachments (Terms of Use)
lsmod.txt (deleted)
2005-04-07 17:58 UTC, Ed Ciechanowski
no flags Details
LSPCI output for ICH6 system in AHCI mode (deleted)
2005-04-07 17:58 UTC, Ed Ciechanowski
no flags Details

Description Ed Ciechanowski 2005-04-07 17:53:10 UTC
Description of problem:
When installing RHEL3 U5 Beta release to an SATA drive with the BIOS set to 
AHCI mode the installation will complete. After rebooting, logging in, and 
running lsmod you can see that the AHCI driver is not loaded at all. The lsmod 
out put shows only the ATA_PIIX driver being loaded. Attached LSPCI.txt and 
lsmod.txt files.

Version-Release number of selected component (if applicable):
2.4.21-31.EL

How reproducible:
When installing RHEL3 U5 Beta release to an SATA drive with the BIOS set to 
AHCI mode the installation will complete. After rebooting, logging in, and 
running lsmod you can see that the AHCI driver is not loaded at all. A lsmod 
output shows only the ATA_PIIX driver being loaded. Attached LSPCI.txt and 
lsmod.txt files.

or

When installing RHEL3 U5 Beta release to an PATA drive with an additional SATA 
drive attached and with the BIOS set to AHCI mode the installation will 
complete. After rebooting, logging in, and running lsmod you can see that the 
AHCI driver is not loaded at all. A lsmod output shows only the ATA_PIIX 
driver being loaded.

Also

After installing RHEL3 U5 Beta release to any type of drive with BIOS set to 
IDE. If you change the BIOS from IDE to AHCI. After rebooting, logging in, and 
running lsmod you can see that the AHCI driver is not loaded at all. A lsmod 
output shows only the ATA_PIIX driver being loaded.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
The ata_piix driver is loading when the BIOS is set to AHCI mode.

Expected results:
Expedted the AHCI driver to be loading in these configurations.


Additional info:
I believe this should be loading the AHCI driver when AHCI is set in the BIOS.

Comment 1 Ed Ciechanowski 2005-04-07 17:55:02 UTC
Issue Tracker 70130

Comment 2 Ed Ciechanowski 2005-04-07 17:58:01 UTC
Created attachment 112823 [details]
lsmod.txt

lsmod

Comment 3 Ed Ciechanowski 2005-04-07 17:58:58 UTC
Created attachment 112824 [details]
LSPCI output for ICH6 system in AHCI mode

lspci

Comment 4 Ed Ciechanowski 2005-08-29 16:56:52 UTC
This has been fixed in the RHEL3 U5 Development cycle. Closing this bug. IT 
has been closed for some time now. 

Comment 5 Ernie Petrides 2005-08-29 19:49:08 UTC
In light of the Issue Tracker comment "Correct works as designed, can close.",
I'm changing the disposition of this bug report to CLOSED/NOTABUG.

Comment 6 Ernie Petrides 2005-08-29 19:51:47 UTC
*** Bug 154139 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.