Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154123 - mysql depends on perl-DBD-MySQL and vice versa
Summary: mysql depends on perl-DBD-MySQL and vice versa
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: mysql
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tom Lane
QA Contact: David Lawrence
URL:
Whiteboard:
: 154124 154125 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-07 17:05 UTC by Joerg Hinz
Modified: 2013-07-03 03:05 UTC (History)
1 user (show)

Fixed In Version: RHBA-2005-471
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-19 19:05:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:471 normal SHIPPED_LIVE mysql bug fix update 2005-06-09 04:00:00 UTC

Description Joerg Hinz 2005-04-07 17:05:28 UTC
From Bugzilla Helper:
User-Agent: Opera/8.0 (Windows NT 5.0; U; en)

Description of problem:
You cannot install mysql because it depends on perl-DBD-MySQL, and you cannot 
install perl-DBD-MySQL because it depends on mysql!



Version-Release number of selected component (if applicable):
perl-DBD-MySQL-2.1021-3 mysql-3.23.58-1

How reproducible:
Always

Steps to Reproduce:
1. rpm -i perl-DBD-MySQL
2. rpm -i mysql
3.
  

Actual Results:  Because of a vice-versa-dependency you cannot install mysql and/or perl-DBD-
MySQL...



Expected Results:  perl-DBD-MySQL should depend on mysql, but mysql should NOT depend on perl-DBD-
MySQL

Additional info:

Comment 1 Tom Lane 2005-04-07 18:14:06 UTC
The dependency is actually required, though arguably it is in the wrong
subpackage --- see bug #66349.  In the meantime the solution is to install both
packages together.

Comment 2 Tom Lane 2005-04-07 18:15:34 UTC
*** Bug 154124 has been marked as a duplicate of this bug. ***

Comment 3 Tom Lane 2005-04-07 18:16:30 UTC
*** Bug 154125 has been marked as a duplicate of this bug. ***

Comment 4 Tom Lane 2005-04-08 23:41:38 UTC
Fixed in devel tip (4.1.11) --- bug still open for back branches, however.

Comment 5 Joerg Hinz 2005-04-13 12:58:43 UTC
Why don't you fix it in the stable, too?

The solution to install both packages together might work on a manual 
installation, but on a script-driven-installation, where packages are installed 
one by one, you will fail.

Comment 6 Tom Lane 2005-04-13 14:06:37 UTC
As I said, the bug is still open.

Comment 7 Tom Lane 2005-05-13 16:15:54 UTC
Fix pushed into RHEL4 with current update; still an open issue for RHEL3.

Comment 8 Tim Powers 2005-06-09 11:43:04 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-471.html


Comment 9 Joerg Hinz 2005-11-10 12:42:21 UTC
Will it ever be fixed in RHEL3?

Comment 10 Tom Lane 2005-11-10 16:05:36 UTC
Hm, yes, this bug should have been left open.  Thanks for the reminder.

I fear this bug by itself isn't enough to prompt us to turn mysql in RHEL3,
so it will have to wait for something else to come along.  But it should be
open in the meantime so I don't forget when there's an opportunity.

Comment 11 Red Hat Bugzilla 2007-02-05 19:31:02 UTC
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.

Comment 12 RHEL Product and Program Management 2007-10-19 19:05:04 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.