Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154117 - lpstat/lpq always shows empty queue with remote server
Summary: lpstat/lpq always shows empty queue with remote server
Keywords:
Status: CLOSED DUPLICATE of bug 90619
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-07 16:04 UTC by Pierre Girard
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-07 16:40:20 UTC


Attachments (Terms of Use)

Description Pierre Girard 2005-04-07 16:04:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
Using the command lpstat or lpr never shows anything in the queue as if no jobs were printing.  The jobs are properly submitted from the client to the server as you can see them come out.  Also when you connect to the server you can see that there are queued jobs.




Version-Release number of selected component (if applicable):
cups-1.1.22-0.rc1.8.5

How reproducible:
Always

Steps to Reproduce:
1. lp -d printer somefile.ps
2. lpstat printer


Actual Results:  client[~]> lpstat hp23
client[~]>

server04[~]> lpstat hp23
hp23-329                user1@client01.domain.ca  712646   Apr 06 10:33


Expected Results:  client[~]> lpstat hp23
hp23-329                user1@client01.domain.ca  712646   Apr 06 10:33

server04[~]> lpstat hp23
hp23-329                user1@client01.domain.ca  712646   Apr 06 10:33


Additional info:

Note that the print server is a sparc with solaris installed but i doubt this make a difference

I don't know if this is related or not but lpstat doesn't give any error messages when the printer doesn't exist:
client[~]> lpstat thisprinterdoesnotexist
client[~]> lpq -Pthisisbogus
lpq: Unknown destination "thisisbogus"!

Comment 1 Pierre Girard 2005-04-07 16:36:07 UTC
My problem seems very similar to bug #90619 (Redhat 9)
It seems this is a "feature" of cups, will it ever be fixed?  Should i just
start installing lprng everywhere?


Comment 2 Tim Waugh 2005-04-07 16:40:20 UTC

*** This bug has been marked as a duplicate of 90619 ***


Note You need to log in before you can comment on or make changes to this bug.