Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154114 - (i128) Logout from X hangs system
Summary: (i128) Logout from X hangs system
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 3
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL: https://bugs.freedesktop.org/show_bug...
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-04-07 15:43 UTC by William D. Hamblen
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-14 00:56:54 UTC


Attachments (Terms of Use)
xorg.conf from an affected machine (deleted)
2005-04-07 15:44 UTC, William D. Hamblen
no flags Details
Xorg.0.log from an affected machine (deleted)
2005-04-07 15:48 UTC, William D. Hamblen
no flags Details


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 2932 None None None Never

Description William D. Hamblen 2005-04-07 15:43:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

Description of problem:
Number 9 Revolution 4 video card.  Problem occurred with non-updated brand new FC3 install and also after I patched everything (including kernel and xorg-x11).  It only seems to happen after the second logout from X.   I already tried commenting out "Load dri" in xorg.xonf and that did not help.

The system is totally dead after the second logout.  Won't respond to pings, keyboard, or mouse.  Only the hardware reset button.

Version-Release number of selected component (if applicable):
kernel-2.6.10-1.770_FC3 xorg-x11-6.8.2-1.FC3.13

How reproducible:
Always

Steps to Reproduce:
1. Login at GUI login screen
2. Logout
3. Login again
4. Logout


Actual Results:  System totally locked up with blank screen and no response to ping, kybd, mouse.

Expected Results:  New login screen.

Additional info:

lspci -v output

01:00.0 VGA compatible controller: Number 9 Computer Company Revolution 4 (rev 01) (prog-if 00 [VGA])
        Subsystem: Number 9 Computer Company: Unknown device 0023
        Flags: bus master, 66Mhz, medium devsel, latency 0, IRQ 11
        Memory at e3000000 (32-bit, prefetchable) [size=16M]
        Memory at e2000000 (32-bit, prefetchable) [size=16M]
        Memory at e1000000 (32-bit, non-prefetchable) [size=4K]
        Memory at e0800000 (32-bit, non-prefetchable) [size=64K]
        I/O ports at d800 [size=256]
        Expansion ROM at e1ff0000 [disabled] [size=64K]
        Capabilities: [80] AGP version 1.0
        Capabilities: [90] Power Management version 1

Comment 1 William D. Hamblen 2005-04-07 15:44:52 UTC
Created attachment 112813 [details]
xorg.conf from an affected machine

Comment 2 William D. Hamblen 2005-04-07 15:48:46 UTC
Created attachment 112814 [details]
Xorg.0.log from an affected machine

This is the log file after a hardware reset / reboot but before anyone has
logged in at the console.

Comment 3 Mike A. Harris 2005-04-08 11:27:25 UTC
The "i128" hardware does not have DRI support at all, so disabling DRI
should have no visible effect.  While we do not have this hardware
available for troubleshooting/debugging, you can file a bug report
to X.org directly, at http://bugs.freedesktop.org in the "xorg"
component.

Once you have filed your bug report in X.Org bugzilla, please attach
your config and log file there also, and paste the URL of the X.Org
bug report here and we will track the issue in their bugzilla.

Troubleshooting tips:
Try disabling acceleration by adding the following to the device section
of the config file and restarting the X server:

    Option "noaccel"

If this prevents the problem from occuring, be sure to indicate that in
the X.Org bug report also.  After that, comment that out, and try the
various XaaNo options listed in the xorg.conf manpage one at a time and/or
in combinations to see if you can narrow down the particular primitive
causing the problems.

It's also possible the problem is due to the video state not being
properly saved and restored by the driver correctly.  A problem of this
nature will likely require someone who has physical access to the video
card, and can reproduce the problem to try to debug it.  There are some
X.Org developers who do still have i128 hardware available and might
be able to do this once you've filed your report there.

Hopefully this will help you to narrow the issue down.




Comment 4 Mike A. Harris 2005-04-08 11:29:02 UTC
Setting bug status to "NEEDINFO", awaiting X.Org bugzilla ID for
tracking.

Comment 5 ajax 2005-04-08 14:53:31 UTC
filed upstream as:

https://bugs.freedesktop.org/show_bug.cgi?id=2932

Comment 6 Mike A. Harris 2005-04-14 00:56:54 UTC
Thanks, setting status to "UPSTREAM" and adding to our tracker.


Note You need to log in before you can comment on or make changes to this bug.