Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154111 - amanda does not rebuild
Summary: amanda does not rebuild
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: amanda
Version: 2.1
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Lukas Vrabel
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-07 14:29 UTC by Brian Brock
Modified: 2015-01-08 00:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-28 14:11:30 UTC


Attachments (Terms of Use)

Description Brian Brock 2005-04-07 14:29:29 UTC
amanda does not rebuild in the current 2.1 AS or 2.1 AW ia64 environment.

amanda-2.4.4p3-1.21as
amanda-2.4.4p3-1.21as.1

Error randomly varies between two cases, occasionally not occuring.


Steps to Reproduce:
rpm -ihv amanda*src.rpm
rpmbuild -ba amanda.spec


Actual results:

echo '#define CC "ia64-redhat-linux-gcc"' > genversion.h.new
echo '#define BUILT_DATE "'`date`'"' >> genversion.h.new
echo '#define BUILT_MACH "'`uname -a || echo UNKNOWN HOST`'"' >> genversion.h.new
mv genversion.h.new genversion.h
if ia64-redhat-linux-gcc -DHAVE_CONFIG_H -I. -I. -I../config -I./../regex-src  
 -O2 -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE   -MT versuff.o -MD -MP -MF
".deps/versuff.Tpo" -c -o versuff.o versuff.c; \
then mv -f ".deps/versuff.Tpo" ".deps/versuff.Po"; else rm -f
".deps/versuff.Tpo"; exit 1; fi
if /bin/sh ../libtool --mode=compile ia64-redhat-linux-gcc -DHAVE_CONFIG_H -I.
-I. -I../config -I./../regex-src    -O2 -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE  
-MT pipespawn.lo -MD -MP -MF ".deps/pipespawn.Tpo" -c -o pipespawn.lo pipespawn.c; \
then mv -f ".deps/pipespawn.Tpo" ".deps/pipespawn.Plo"; else rm -f
".deps/pipespawn.Tpo"; exit 1; fi
mv: cannot stat `.deps/versuff.Tpo': No such file or directory
make[1]: *** [versuff.o] Error 1
make[1]: *** Waiting for unfinished jobs....
 ia64-redhat-linux-gcc -DHAVE_CONFIG_H -I. -I. -I../config -I./../regex-src -O2
-D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -MT pipespawn.lo -MD -MP -MF
.deps/pipespawn.Tpo -c pipespawn.c  -fPIC -DPIC -o .libs/pipespawn.o
 ia64-redhat-linux-gcc -DHAVE_CONFIG_H -I. -I. -I../config -I./../regex-src -O2
-D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -MT pipespawn.lo -MD -MP -MF
.deps/pipespawn.Tpo -c pipespawn.c -o pipespawn.o >/dev/null 2>&1
make[1]: Leaving directory `/usr/src/redhat/BUILD/amanda-2.4.4p3/common-src'
make: *** [all-recursive] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.37261 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.37261 (%build)


OR

if /bin/sh ../libtool --mode=compile ia64-redhat-linux-gcc -DHAVE_CONFIG_H -I.
-I. -I../config -I./../regex-src    -O2 -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE  
-MT pipespawn.lo -MD -MP -MF ".deps/pipespawn.Tpo" -c -o pipespawn.lo pipespawn.c; \
then mv -f ".deps/pipespawn.Tpo" ".deps/pipespawn.Plo"; else rm -f
".deps/pipespawn.Tpo"; exit 1; fi
if /bin/sh ../libtool --mode=compile ia64-redhat-linux-gcc -DHAVE_CONFIG_H -I.
-I. -I../config -I./../regex-src    -O2 -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE  
-MT sl.lo -MD -MP -MF ".deps/sl.Tpo" -c -o sl.lo sl.c; \
then mv -f ".deps/sl.Tpo" ".deps/sl.Plo"; else rm -f ".deps/sl.Tpo"; exit 1; fi
if /bin/sh ../libtool --mode=compile ia64-redhat-linux-gcc -DHAVE_CONFIG_H -I.
-I. -I../config -I./../regex-src    -O2 -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE  
-MT match.lo -MD -MP -MF ".deps/match.Tpo" -c -o match.lo match.c; \
then mv -f ".deps/match.Tpo" ".deps/match.Plo"; else rm -f ".deps/match.Tpo";
exit 1; fi
mv: cannot stat `.deps/util.Tpo': No such file or directory
make[1]: *** [util.o] Error 1
make[1]: *** Waiting for unfinished jobs....
 ia64-redhat-linux-gcc -DHAVE_CONFIG_H -I. -I. -I../config -I./../regex-src -O2
-D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -MT pipespawn.lo -MD -MP -MF
.deps/pipespawn.Tpo -c pipespawn.c  -fPIC -DPIC -o .libs/pipespawn.o
 ia64-redhat-linux-gcc -DHAVE_CONFIG_H -I. -I. -I../config -I./../regex-src -O2
-D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -MT sl.lo -MD -MP -MF .deps/sl.Tpo -c sl.c
 -fPIC -DPIC -o .libs/sl.o
 ia64-redhat-linux-gcc -DHAVE_CONFIG_H -I. -I. -I../config -I./../regex-src -O2
-D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -MT match.lo -MD -MP -MF .deps/match.Tpo -c
match.c  -fPIC -DPIC -o .libs/match.o
 ia64-redhat-linux-gcc -DHAVE_CONFIG_H -I. -I. -I../config -I./../regex-src -O2
-D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -MT sl.lo -MD -MP -MF .deps/sl.Tpo -c sl.c
-o sl.o >/dev/null 2>&1
 ia64-redhat-linux-gcc -DHAVE_CONFIG_H -I. -I. -I../config -I./../regex-src -O2
-D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -MT pipespawn.lo -MD -MP -MF
.deps/pipespawn.Tpo -c pipespawn.c -o pipespawn.o >/dev/null 2>&1
 ia64-redhat-linux-gcc -DHAVE_CONFIG_H -I. -I. -I../config -I./../regex-src -O2
-D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -MT match.lo -MD -MP -MF .deps/match.Tpo -c
match.c -o match.o >/dev/null 2>&1
make[1]: Leaving directory `/usr/src/redhat/BUILD/amanda-2.4.4p3/common-src'
make: *** [all-recursive] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.38515 (%build)


Expected results:
build reliably succeeds

Comment 1 Jay Fenlason 2005-04-07 14:49:45 UTC
This is a symptom of a bug in automake:   
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=137096 
Automake uses the same temporary file name for two different variants of an 
object file, resulting in a race condition.  This problem only manifests on 
SMP machines, because on uniprocessor machines, the builds are serialized so 
the duplicate temp file name can't cause any harm. 
 
 

Comment 3 Lukas Vrabel 2007-03-28 14:11:30 UTC
Only security related issues are handled for RHEL2 


Note You need to log in before you can comment on or make changes to this bug.