Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154096 - libuser's ./configure doesn't detect python version
Summary: libuser's ./configure doesn't detect python version
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libuser
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Miloslav Trmač
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-07 08:38 UTC by Joshua Nichols
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 0.53.5-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-15 14:03:47 UTC


Attachments (Terms of Use)

Description Joshua Nichols 2005-04-07 08:38:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050331 Firefox/1.0.2

Description of problem:
I'm trying to get libuser running on Gentoo Linux, and it seems that the configure script hardcodes the python version to 2.2. I am using python-2.3, and this causes compilation to fail because it can't find the python headers, because its in /usr/include/python2.3, not /usr/include/python2.2, as it assumes.

I also can't seem to find any homepage for libuser, or a place to download it in any format other than RPMs or SRPMS...

Version-Release number of selected component (if applicable):
libuser-0.53.3-2

How reproducible:
Always

Steps to Reproduce:
1. Have python-2.3 installed
2. Run ./configure
3. make
4. watch make fail
  

Actual Results:  Make fails due to a missing header file. It attempts to find it in /usr/include/python-2.2, whichh doesn't exist when python-2.3 is installed.

Additional info:

Comment 1 Joshua Nichols 2005-04-07 08:55:32 UTC
I apparently had overlooked the --with-python-version flag for ./configure.
Regardless, it would seem like something configure should be able to detect
automatically.

Comment 2 Miloslav Trmač 2005-04-15 14:03:22 UTC
libuser is available via anonymous cvs at
:pserver:anonymous@elvis.redhat.com/usr/local/CVS, module "libuser";
there are no separate tarball releases currently.

Python autodetection added in libuser-0.53.5-1. Thanks for your report.



Note You need to log in before you can comment on or make changes to this bug.