Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154083 - Use real mount rather than busybox mount
Summary: Use real mount rather than busybox mount
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: busybox
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Ivana Varekova
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-07 05:24 UTC by Mike MacCana
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-28 12:53:40 UTC


Attachments (Terms of Use)

Description Mike MacCana 2005-04-07 05:24:40 UTC
Description of problem:
Busybox mount can't mount devices using labels. This is a headache for most
users - it's inconsistent with the normal command, and seems to be the basis of
anaconda not mounting all the correct devices during rescues.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.linux rescue
  
Actual results:
Missing devices requiring manual mounting.
A mount command that doesn't consistently with the rest of RHEL (mount, fsck,
/etc/fstab, etc).


Expected results:
mount should work normally. Using the real mount command seems preferable to
adding label support to busybox (see
http://www.busybox.net/lists/busybox/2003-November/009906.html), especially now
we don't have to worry about floppy rescues.

Additional info:

Comment 4 Ivana Varekova 2007-03-28 12:53:40 UTC
This is feature request and this feature is not add in upstream version. It
should be added to upstream/devel branch to be tested at first. So I'm closing
this bug.


Note You need to log in before you can comment on or make changes to this bug.