Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154079 - Removed RPMs still in database
Summary: Removed RPMs still in database
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rpm
Version: 3.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-07 02:56 UTC by Barry
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-26 22:13:21 UTC


Attachments (Terms of Use)

Description Barry 2005-04-07 02:56:08 UTC
Description of problem:
Removing a some packages through "rpm -e" does not remove it from the rpm
database and seg faults instead.

Version-Release number of selected component (if applicable):
RPM version 4.2.3

How reproducible:
Every time

Steps to Reproduce:
1.rpm -e -vv --nodeps OPC
2.rpm -e -vv --nodeps OPCPERF
3.rpm -e -vv --nodeps OPCCOMM
  
Actual results:
root@lx-chacpt12 root# rpm -e -vv --nodeps OPC
D: opening  db environment /var/lib/rpm/Packages joinenv
D: opening  db index       /var/lib/rpm/Packages rdonly mode=0x0
D: locked   db index       /var/lib/rpm/Packages
D: opening  db index       /var/lib/rpm/Name rdonly mode=0x0
D:  read h#     974 Header sanity check: OK
D: closed   db index       /var/lib/rpm/Name
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm/Packages
D: opening  db environment /var/lib/rpm/Packages joinenv
D: opening  db index       /var/lib/rpm/Packages create mode=0x42
D: mounted filesystems:
D:     i    dev bsize       bavail       iavail mount point
D:     0 0x0802  4096      1390780      1073787 /
D:     1 0x0002  1024            0           -1 /proc
D:     2 0x0007  1024            0           -1 /dev/pts
D:     3 0x0008  1024            0           -1 /proc/bus/usb
D:     4 0x0801  1024        59055        26041 /boot
D:     5 0x0807  4096      9333422      6965935 /logs
D:     6 0x0009  4096       994437       994436 /dev/shm
D:     7 0x0803  4096       429371       260268 /var
D:     8 0x0806  4096       227933       130455 /var/maestro
D:     9 0x000a  1024            0           -1 /home
D:    10 0x000b  1024            0           -1 /auto
D:    11 0x000c  8192      3841148     18651359 /home/s_pspact
D:    12 0x000f  8192       947560     28052225 /auto/tp
D:    13 0x0012  8192      3841148     18651359 /home/bmoy
D: sanity checking 1 elements
D: computing 53 file fingerprints
Segmentation fault
root@lx-chacpt12 root# rpm -e -vv --nodeps OPCPERF
D: opening  db environment /var/lib/rpm/Packages joinenv
D: opening  db index       /var/lib/rpm/Packages rdonly mode=0x0
D: locked   db index       /var/lib/rpm/Packages
D: opening  db index       /var/lib/rpm/Name rdonly mode=0x0
D:  read h#     265 Header sanity check: OK
D: closed   db index       /var/lib/rpm/Name
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm/Packages
D: opening  db environment /var/lib/rpm/Packages joinenv
D: opening  db index       /var/lib/rpm/Packages create mode=0x42
D: mounted filesystems:
D:     i    dev bsize       bavail       iavail mount point
D:     0 0x0802  4096      1390780      1073787 /
D:     1 0x0002  1024            0           -1 /proc
D:     2 0x0007  1024            0           -1 /dev/pts
D:     3 0x0008  1024            0           -1 /proc/bus/usb
D:     4 0x0801  1024        59055        26041 /boot
D:     5 0x0807  4096      9333422      6965935 /logs
D:     6 0x0009  4096       994437       994436 /dev/shm
D:     7 0x0803  4096       429371       260268 /var
D:     8 0x0806  4096       227933       130455 /var/maestro
D:     9 0x000a  1024            0           -1 /home
D:    10 0x000b  1024            0           -1 /auto
D:    11 0x000c  8192      3841118     18651359 /home/s_pspact
D:    12 0x000f  8192       947560     28052218 /auto/tp
D:    13 0x0012  8192      3841118     18651359 /home/bmoy
D: sanity checking 1 elements
D: computing 9 file fingerprints
D: computing file dispositions
D: opening  db index       /var/lib/rpm/Basenames create mode=0x42
D: ========== --- OPCPERF-7.23-1 i386-Linux 0x0
D:     erase: OPCPERF-7.23-1 has 9 files, test = 0
D: opening  db index       /var/lib/rpm/Name create mode=0x42
D:  read h#     265 Header sanity check: OK
D: opening  db index       /var/lib/rpm/Triggername create mode=0x42
D:     erase: %preun(OPCPERF-7.23-1) asynchronous scriptlet start
D:     erase: %preun(OPCPERF-7.23-1)    execv(/bin/sh) pid 3013
+ /opt/OV/bin/OpC/install/perfrpmpreun
/var/tmp/rpm-tmp.54354: line 2: /opt/OV/bin/OpC/install/perfrpmpreun: No such
file or directory
D:     erase: waitpid(3013) rc 3013 status 7f00 secs 0.004
error: %preun(OPCPERF-7.23-1) scriptlet failed, exit status 127
D: closed   db index       /var/lib/rpm/Triggername
D: closed   db index       /var/lib/rpm/Basenames
D: closed   db index       /var/lib/rpm/Name
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm/Packages
root@lx-chacpt12 root# rpm -e -vv --nodeps OPCCOMM
D: opening  db environment /var/lib/rpm/Packages joinenv
D: opening  db index       /var/lib/rpm/Packages rdonly mode=0x0
D: locked   db index       /var/lib/rpm/Packages
D: opening  db index       /var/lib/rpm/Name rdonly mode=0x0
D:  read h#     531 Header sanity check: OK
D: closed   db index       /var/lib/rpm/Name
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm/Packages
D: opening  db environment /var/lib/rpm/Packages joinenv
D: opening  db index       /var/lib/rpm/Packages create mode=0x42
D: mounted filesystems:
D:     i    dev bsize       bavail       iavail mount point
D:     0 0x0802  4096      1390780      1073787 /
D:     1 0x0002  1024            0           -1 /proc
D:     2 0x0007  1024            0           -1 /dev/pts
D:     3 0x0008  1024            0           -1 /proc/bus/usb
D:     4 0x0801  1024        59055        26041 /boot
D:     5 0x0807  4096      9333422      6965935 /logs
D:     6 0x0009  4096       994437       994436 /dev/shm
D:     7 0x0803  4096       429370       260267 /var
D:     8 0x0806  4096       227933       130455 /var/maestro
D:     9 0x000a  1024            0           -1 /home
D:    10 0x000b  1024            0           -1 /auto
D:    11 0x000c  8192      3841114     18651357 /home/s_pspact
D:    12 0x000f  8192       947560     28052217 /auto/tp
D:    13 0x0012  8192      3841114     18651357 /home/bmoy
D: sanity checking 1 elements
D: computing 14 file fingerprints
D: computing file dispositions
D: opening  db index       /var/lib/rpm/Basenames create mode=0x42
D: ========== --- OPCCOMM-7.16-1 i386-Linux 0x0
D:     erase: OPCCOMM-7.16-1 has 14 files, test = 0
D: opening  db index       /var/lib/rpm/Name create mode=0x42
D:  read h#     531 Header sanity check: OK
D: opening  db index       /var/lib/rpm/Triggername create mode=0x42
D:     erase: %preun(OPCCOMM-7.16-1) asynchronous scriptlet start
D:     erase: %preun(OPCCOMM-7.16-1)    execv(/bin/sh) pid 3017
+ /opt/OV/bin/OpC/install/commrpmpreun
/var/tmp/rpm-tmp.24585: line 2: /opt/OV/bin/OpC/install/commrpmpreun: No such
file or directory
D:     erase: waitpid(3017) rc 3017 status 7f00 secs 0.004
error: %preun(OPCCOMM-7.16-1) scriptlet failed, exit status 127
D: closed   db index       /var/lib/rpm/Triggername
D: closed   db index       /var/lib/rpm/Basenames
D: closed   db index       /var/lib/rpm/Name
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm/Packages

Expected results:


Additional info:

Comment 1 Paul Nasrat 2005-04-07 07:56:56 UTC
Where do the OPC* rpms come from?

Can you attach the output of strace running 

strace -o rpm.strace rpm -e --nodeps OPC

Can you do 
ulimit -c unlimited
rpm -e --nodeps OPC

And upload the corefile somewhere and paste a url here (it will be too big for
bugzilla).

Also rpm -q rpm so I know exactly which NEVR of rpm this so I can get the right
debuginfo.

Comment 2 Paul Nasrat 2005-09-26 22:13:21 UTC
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproduceable or has been fixed in
a later update for this product.  If you have further details, feel free to
reopen the report with the additional details attached.


Note You need to log in before you can comment on or make changes to this bug.