Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154075 - iputils - rdisc startup service reports failures
Summary: iputils - rdisc startup service reports failures
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: iputils
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Radek Vokal
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-07 01:58 UTC by Michal Jaegermann
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-07 07:25:42 UTC


Attachments (Terms of Use)

Description Michal Jaegermann 2005-04-07 01:58:25 UTC
Description of problem:

It looks like that a new startup script showed up which looks, after
some inspection, like something which tries to find LAN routers.
OK, but I have only a simple switch on my LAN and, as documented in
'man rdisc', this is causing exit with a non-zero status and a consistent
[FAILED] in a startup.  Sure, I can turn it off or ignore it but the
service appears to default to "on" and people with less understanding will
just see that something is wrong when a machine starts.  Conditioning
them to ignore failures does not sound like an exciting idea.

It seems that this script should always succeed because not finding
routers on LAN is not really an error (unless they are really there :-)
or the service should default to off.  Those who really have routers will
likely know anyway what to do to turn it on if desired.

Version-Release number of selected component (if applicable):
iputils-20020927-21

How reproducible:
always

Comment 1 Radek Vokal 2005-04-07 07:23:04 UTC
That's my *oups*. This service shouldn't be started as default 'cos it's for
experienced users only :)  I've fixed the init script in the new rawhide version
of iputils. 


Note You need to log in before you can comment on or make changes to this bug.