Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154069 - missing dependency for postun scriptlet: mkfontdir
Summary: missing dependency for postun scriptlet: mkfontdir
Keywords:
Status: CLOSED DUPLICATE of bug 158577
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-06 23:46 UTC by Gerald Britton
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-26 22:11:52 UTC


Attachments (Terms of Use)

Description Gerald Britton 2005-04-06 23:46:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
the package is missing a postun dependency on mkfontdir resulting in removal
of it and xorg-x11-font-utils succeeding only when they're removed in the
proper order.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start with no X or fonts installed
2. yum install fonts-xorg-100dpi
3. rpm -e fonts-xorg-100dpi-6.8.1.1-1 ttmkfdir-3.0.9-16 xorg-x11-font-utils-6.8.2-19 xorg-x11-xfs-6.8.2-19 chkfontpath-1.10.0-4
   

Actual Results:  /var/tmp/rpm-tmp.16594: line 3: /usr/X11R6/bin/mkfontdir: No such file or directory
error: %postun(fonts-xorg-100dpi-6.8.1.1-1.noarch) scriptlet failed, exit status 127


Expected Results:  removals should occur in order to not remove mkfontdir before it's needed.

Additional info:

Comment 1 Mike A. Harris 2005-04-08 10:00:10 UTC
This looks like an rpm bug.  The fonts-xorg-100dpi-6.8.1.1-1 package has
the following Requires present:

%package 100dpi
Summary: A set of 100dpi resolution fonts for the X Window System.
Group: User Interface/X
Requires(post): %{_x11bindir}/mkfontdir, chkfontpath
Requires(postun): %{_x11bindir}/mkfontdir
Obsoletes: XFree86-100dpi-fonts
Obsoletes: xorg-x11-100dpi-fonts

%description 100dpi
A set of 100 dpi fonts used by the X window system.



If rpm is uninstalling the package that provides mkfontdir (which is
currently xorg-x11-font-utils) before uninstalling the packages that
require mkfontdir, and neither "--nodeps" nor "--force" were supplied,
then it's doing things in the wrong order if the package has the correct
Requires present.

CC'ing jbj and nasrat for comment from the rpm side of things.



Comment 2 Florian La Roche 2005-04-08 10:44:04 UTC
rpm does no ordering for removals.


Comment 3 Mike A. Harris 2005-04-08 16:20:05 UTC
In order to resolve the problem being reported here, rpm needs to honour
the dependancies the packager has specified in the spec file.  This would
then seem to be a bug in rpm.  If anyone has alternate suggestions for how
to resolve this issue, please add them in a comment below.

Reassigning to rpm component.

Comment 4 Paul Nasrat 2005-09-26 22:11:52 UTC
rpm 4.4.1-11 has erase ordering although work still needs to be done.  Closing
as a dupe of current outstanding erasure ordering bug.


*** This bug has been marked as a duplicate of 158577 ***


Note You need to log in before you can comment on or make changes to this bug.