Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154067 - postinstall script incorrectly runs mkfontdir
Summary: postinstall script incorrectly runs mkfontdir
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: urw-fonts
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-06 23:30 UTC by Gerald Britton
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: F7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-15 13:37:47 UTC


Attachments (Terms of Use)

Description Gerald Britton 2005-04-06 23:30:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
urw-fonts's postinstall scriptlet runs mkfontdir supplying non-existant
encodings directories resulting in fonts.dir failing to be created.

Version-Release number of selected component (if applicable):
urw-fonts-2.3-1

How reproducible:
Always

Steps to Reproduce:
1. yum install urw-fonts (prior to any X install)
2.
3.
  

Actual Results:  no fonts.dir created

Expected Results:  fonts.dir created properly

Additional info:

Commentary from mharris on the correct solution to this issue from IRC:

<mharris> xfs initscript runs mkfontdir in the same dirs always anyway, which
          invalidates mkfontdir being called with any args from any %post
          script
<mharris> I've told our font packagers 1000 times do not pass args to ttmkfdir
          or mkfontdir, as they will get blown away anyway, the first time xfs
          starts up
<mharris> Well, not necessarily the first time, but some time later perhaps,
          giving users different results
<mharris> All font packages should run mkfontdir/ttmkfdir/mkfontscale *only*
          the same way the xorg-x11.spec file does, and xfs.init
<mharris> Anything else will be overwritten.
<mharris> The only exception, is fonts.scale files in Type1 font directories.
<mharris> Because we do not ship type1inst
<mharris> At some point I plan on testing mkfontscale with all type1 fonts we
          ship and comparing the results it generates with the supplied
          fonts.scale files.
<mharris> If the results are identical, or it can be proven the static
          fonts.scale files are wrong in some way, I'll be calling mkfontscale
          on Type1 fonts always too.
<mharris> The reason for this, is 100% consistency.
<mharris> If args are needed absolutely for some certain font, then either the
          font is buggy, or the defaults in the tools aren't quite perfect and
          should be changed.

<mharris> You can paste what I said into the bug report too if you like.

Comment 1 Ngo Than 2007-06-15 13:37:47 UTC
it's fixed in FC6 and newest.


Note You need to log in before you can comment on or make changes to this bug.