Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1540606 - [3.7] [OnlineStarter][free-stg][free-int]"Failed create pod sandbox"---deploy failed
Summary: [3.7] [OnlineStarter][free-stg][free-int]"Failed create pod sandbox"---deploy...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.7.z
Assignee: Ravi Sankar
QA Contact: Meng Bo
URL:
Whiteboard:
Depends On: 1509799 1540608
Blocks: 1512717
TreeView+ depends on / blocked
 
Reported: 2018-01-31 14:10 UTC by Ben Bennett
Modified: 2018-04-05 09:37 UTC (History)
30 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Openshift node was not waiting enough for the VNID as master assigns vnid and it could take a while to propagate to the node. Consequence: Pod creation fails Fix: Increase timeout from 1 to 5 secs for fetching VNID on node. Result: Should allow pod creation to succeed.
Clone Of: 1509799
Environment:
Last Closed: 2018-04-05 09:37:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift ose pull 1044 None None None 2018-02-02 14:12:55 UTC
Origin (Github) 17243 None None None 2018-01-31 14:10:10 UTC
Red Hat Knowledge Base (Solution) 3337301 None None None 2018-01-31 14:10:10 UTC
Red Hat Product Errata RHBA-2018:0636 None None None 2018-04-05 09:37:57 UTC

Comment 1 Ravi Sankar 2018-01-31 17:44:05 UTC
Fixed by https://github.com/openshift/ose/pull/1044

Comment 3 Hongan Li 2018-02-14 02:08:48 UTC
verified in atomic-openshift-3.7.29-1.git.0.0e0f138 and cannot reproduce the issue.

Comment 7 errata-xmlrpc 2018-04-05 09:37:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0636


Note You need to log in before you can comment on or make changes to this bug.