Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154056 (maxdepth) - xorg-x11 - xfs startup script generates multiple complaints by 'find'
Summary: xorg-x11 - xfs startup script generates multiple complaints by 'find'
Keywords:
Status: CLOSED RAWHIDE
Alias: maxdepth
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
: 155337 (view as bug list)
Depends On:
Blocks: FC4Target
TreeView+ depends on / blocked
 
Reported: 2005-04-06 21:22 UTC by Michal Jaegermann
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-14 00:27:04 UTC


Attachments (Terms of Use)

Description Michal Jaegermann 2005-04-06 21:22:00 UTC
Description of problem:

During a startup the following is spilled on a screen multiple times:

find: warning: you have specified the -maxdepth option after a non-option
argument -type, but options are not positional (-maxdepth affects tests
specified before it as well as those specified after it).  Please specify
options before other arguments.

Well, a fix is spelled out in this warning. :-)

Version-Release number of selected component (if applicable):
xorg-x11-xfs-6.8.2-19

How reproducible:
allways

Comment 1 Mike A. Harris 2005-04-06 22:42:42 UTC
Odd, this worked fine on my test system:


[root@laser TrueType]# find . -type f -maxdepth 1 -cnewer fonts.dir -not -name
'fonts.cache*'
[root@laser TrueType]# touch gbsn00lp.ttf
[root@laser TrueType]# find . -type f -maxdepth 1 -cnewer fonts.dir -not -name
'fonts.cache*'
./gbsn00lp.ttf



Can you cd into a font directory and try those commands?


Comment 2 Mike A. Harris 2005-04-06 23:18:29 UTC
Ok, thanks for reporting this by the way...

It turns out that this problem is just a "warning" in the newest
version of find.  My "find" is a bit older, and does not print this
warning.  The find manpage suggests to put "option" args at the front,
but does not indicate it is mandatory.  While it is only a warning,
the current "find" still executes properly and does the right thing.

Since it turns out this is just a bit of a cosmetic issue of an
ugly warning getting printed, it's not as severe as I had
initially been thinking.  (panicing actually)  ;o)

I've fixed it by moving "maxdepth 1" to the front of the args in
xorg-x11-6.8.2-20, however this new build probably will not get
put into test2, unless there are other major blockers found in
xorg which require a respin for.   ;o/

Nonetheless, I've fixed it and it will be in rawhide after test2.
I will also upload it on people.redhat.com once the new rpms are
built.

I suspect due to the alarmist nature of this bug, even though it
is only cosmetic, we will probably get numerous reports from test2
testers, so I am going to leave this bug open for now to use as
a master duplicate.

Thanks again Michal!


Comment 3 Mike A. Harris 2005-04-08 05:40:03 UTC
xorg-x11-6.8.2-20 successfully built, and will be in Fedora devel soon,
if it isn't there already.

While this bug is resolved now, I've decided to leave it open for a few
days to see how many dupes get reported.  I'm assuming this will get
reported a lot, and also assuming most people do not query closed bugs
in bugzilla before reporting, so once things die down, I'll close
it as fixed in "RAWHIDE".


Comment 4 Lars G 2005-04-08 15:11:50 UTC
new xorg-x11 from rawhide fixed this for me.
thanks!

Comment 5 Mike A. Harris 2005-04-19 10:19:11 UTC
*** Bug 155337 has been marked as a duplicate of this bug. ***

Comment 6 Dave Jones 2005-10-06 20:22:48 UTC
*** Bug 167394 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.