Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154047 - Cannot dynamically link to libc.so.6 when LD_ASSUME_KERNEL=2.2.5
Summary: Cannot dynamically link to libc.so.6 when LD_ASSUME_KERNEL=2.2.5
Keywords:
Status: CLOSED DUPLICATE of bug 116445
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-04-06 20:26 UTC by Robin Green
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-28 02:32:28 UTC


Attachments (Terms of Use)

Description Robin Green 2005-04-06 20:26:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050328 Firefox/1.0.2 Fedora/1.0.2-3

Description of problem:
In the script /usr/bin/firefox, there is still some old code which uses LD_ASSUME_KERNEL=2.2.5, to be compatible with old Java virtual machines. This breaks on the latest glibc:

+ export LD_ASSUME_KERNEL=2.2.5
+ LD_ASSUME_KERNEL=2.2.5
++ /usr/lib/jvm/java-1.5.0-sun-1.5.0.01/jre/plugin/i386/ns7/../../../bin//java -version
++ grep version
grep: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
++ cut -f 3 -d ' '
++ sed -e 's/\"//g'
cut: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
sed: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
+ JVM_VERSION=
+ unset LD_ASSUME_KERNEL

strace shows that glibc.so.6 is being found and opened, but not "understood". Maybe this is related to the LinuxThreads move?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run firefox

Alternatively, just run:
LD_ASSUME_KERNEL=2.2.5 sh

Actual Results:  See above

Expected Results:  No errors; or, alternatively, a more helpful error message, e.g. "LD_ASSUME_KERNEL=2.2.5 is no longer supported".

Additional info:

Comment 1 Robin Green 2005-04-06 20:28:35 UTC
Sorry, I meant libc.so.6, not glibc.so.6, obviously.

Comment 2 Jakub Jelinek 2005-04-06 20:53:37 UTC
What firefox does has been wrong before as well, especially on non-i?86 arches.

The only program that should run with LD_ASSUME_KERNEL=2.2.5 in the environment
is java, not grep, cut or sed.
In FC4t2 LD_LIBRARY_PATH=/lib/obsolete/linuxthreads must be added to the
environment of that program as well.

Comment 3 Hans de Goede 2005-04-18 10:03:06 UTC
I'm seeing this too with a fully up2date rawhide system, very annoying. Please
change status to assigned and fix.


Comment 4 Warren Togami 2005-04-28 02:32:28 UTC

*** This bug has been marked as a duplicate of 116445 ***


Note You need to log in before you can comment on or make changes to this bug.