Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154015 - NFSv4 loopback mount hangs the system
Summary: NFSv4 loopback mount hangs the system
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: nfs-utils
Version: 4
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-06 15:51 UTC by Jared Greenwald
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-27 23:43:30 UTC


Attachments (Terms of Use)

Description Jared Greenwald 2005-04-06 15:51:34 UTC
Description of problem:
Attempt NFSv4 loopback mount never completes.

Version-Release number of selected component (if applicable):
nfs-utils-1.0.7-1

How reproducible:
Attempt NFSv4 loopback mount.

Steps to Reproduce:
- Setup /etc/extports to export a filesystem in a way that NFSv4 understands.
/mnt/testfs     *(rw,fsid=0,insecure,no_subtree_check,sync)
- increase the number of NFSD threads to 32
echo "32" >/etc/sysconfig/nfs
- start nfs service
/etc/init.d/nfs start
- mount the filesystem through loopback as type nfs4
mount -t nfs4 -o nocto,rsize=32768,wsize=32768 localhost:/ /mnt/testfs_loopback
-HANG
  
Actual results:
HANG

Expected results:
loopback mount

Additional info:
This works fine on Gentoo.

Comment 1 Steve Dickson 2005-04-07 19:06:33 UTC
Just to be clear, what is the kernel version your using?

Comment 2 Jared Greenwald 2005-04-08 13:43:32 UTC
I had been running kernel-smp-2.6.11-1.1177_FC4 with nfs-utils-1.0.7-1.  I have
since upgraded to kernel-smp-2.6.11-1.1226_FC4 and nfs-utils-1.0.7-5.

Comment 3 Jared Greenwald 2005-04-08 13:46:59 UTC
It seems to be working now...

# showmount -e
Export list for xxx.xxx.xxx.xxx
/var/tmp *
# mount -t nfs4 -o nocto,rsize=32768.wsize=32768 localhost:/ /mnt/
# mount
...
localhost:/ on /mnt type nfs4 (rw,nocto,rsize=32768.wsize=32768,addr=127.0.0.1)



Note You need to log in before you can comment on or make changes to this bug.