Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1540083 - CLI doesn't return with error message when non existing user is add to the group.
Summary: CLI doesn't return with error message when non existing user is add to the gr...
Keywords:
Status: CLOSED DUPLICATE of bug 1512807
Alias: None
Product: OKD
Classification: Red Hat
Component: Command Line Interface
Version: 3.x
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Juan Vallejo
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-30 09:07 UTC by hardeep
Modified: 2018-01-30 14:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-30 14:41:57 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description hardeep 2018-01-30 09:07:10 UTC
Description of problem:
When we pass non existing user_name in "oadm groups add-users <group_name> <user_name>" command, then the command run successfully without any error. Moreover, In output of "oc get users" command, no such user is created.

Version-Release number of selected component (if applicable):
3.6

How reproducible:


Steps to Reproduce:
1.pass non existing user_name in "oadm groups add-users <group_name> <user_name>" command


Actual results:
cursor move to next line, showing user is successfully added to the group.

Expected results:
An error must be returned to user that "no such user exists".

Additional info:

Comment 1 Juan Vallejo 2018-01-30 14:41:57 UTC
From https://bugzilla.redhat.com/show_bug.cgi?id=1512807#c2

> This is the expected behavior.  These commands are meant to be order independent and must not care if a user exists.  A user can be purely virtual or created at a later date.  Most users cannot list users anyway, so there is no way to provide this feedback to them.

*** This bug has been marked as a duplicate of bug 1512807 ***


Note You need to log in before you can comment on or make changes to this bug.