Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153970 - IrDA-driver smsc-ircc2 needs pnp-functionality
Summary: IrDA-driver smsc-ircc2 needs pnp-functionality
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL: http://dhost.info/mauritzius/down/2.6...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-06 06:55 UTC by Stefan Neufeind
Modified: 2015-01-04 22:18 UTC (History)
3 users (show)

Fixed In Version: 2.6.13-1.1532_FC4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-11-10 20:09:45 UTC


Attachments (Terms of Use)
pnp-patch (deleted)
2005-04-09 07:53 UTC, Stefan Neufeind
no flags Details | Diff

Description Stefan Neufeind 2005-04-06 06:55:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

Description of problem:
On a notebook (BenQ Joybook 7000) the IrDA-device was not detected - though the correct driver smsc_ircc2 is present in the (Fedora) kernel. After searching and trying I found the patch at the attached URL. It adds pnp-functionality to the driver, since on some machines the irda-port is not initialised by the bios.

After applying the patch and rebuilding the kernel IrDA was detected and worked without problems.

Please consider adding this patch to Fedora and submitting it as a patch to the official kernel as well.

Version-Release number of selected component (if applicable):
kernel-2.6.10-1.770_FC3

How reproducible:
Always

Steps to Reproduce:
1.Start machine (notebook in this case) with appropriate IrDA device inside.
2.
3.
  

Actual Results:  Not detected, since not initialised.

Expected Results:  Should be detected. (It is detected with the patch!)

Additional info:

Comment 1 Stefan Neufeind 2005-04-09 07:53:31 UTC
Created attachment 112905 [details]
pnp-patch

from:
http://dhost.info/mauritzius/down/2.6.10-rc2-smsc-ircc2-pnp.patch

Comment 2 Dave Jones 2005-07-15 17:39:37 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 3 Stefan Neufeind 2005-07-16 00:08:14 UTC
Still an issue here. fc4 with kernel 2.6.12-1.1390_FC4.

# modprobe smsc-ircc2
FATAL: Error inserting smsc_ircc2
(/lib/modules/2.6.12-1.1390_FC4/kernel/drivers/net/irda/smsc-ircc2.ko): No such
device

=> this is because the device was not initialised (pnp)

Comment 4 Dave Jones 2005-09-30 06:08:40 UTC
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.


Comment 5 Dave Jones 2005-09-30 09:42:17 UTC
why are you so sure this driver is the correct one btw ?
googling for "benQ Joybook 7000 smsc_ircc2" only finds this bug.


Comment 6 Stefan Neufeind 2005-09-30 10:44:21 UTC
Well, there are a few more hits on Google - but not many I must admit:
http://www.google.de/search?q=joybook+ircc2

Searching for how to get the infrared to work, since it was not autodetected, I
found information of it to be a smsc_ircc2. The only difference with this
device, as I have heard, is that it's not initialised e.g. by bios (PNP), but
that separate PNP-init inside the driver is necessary. With the attached patch
it works. And I have been told that the only thing this patch does is PNP-init
the device. After recompiling the kernel with the patch, I can run irdadump and
see my mobile phone etc. So it works for me.

Comment 7 Dave Jones 2005-09-30 10:53:52 UTC
ok, I'll throw this in the next build, and also see if I can find out why this
hasn't gone upstream yet. It's been around for a while judging from the filename.


Comment 8 Dave Jones 2005-11-10 19:06:33 UTC
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.


Comment 9 Stefan Neufeind 2005-11-10 20:09:12 UTC
Fixed in latest official kernel-release. Thanks a lot.

Comment 10 Stefan Neufeind 2005-11-10 20:09:45 UTC
Fixed in latest official kernel-release. Thanks a lot.


Note You need to log in before you can comment on or make changes to this bug.