Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153963 - SELinux warnings when starting up PostgreSQL first time
Summary: SELinux warnings when starting up PostgreSQL first time
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-06 05:50 UTC by Florin Andrei
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-06 11:30:59 UTC


Attachments (Terms of Use)

Description Florin Andrei 2005-04-06 05:50:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
Fresh minimal install via kickstart, SELinux set to permissive. When launching PostgreSQL for the first time, i get these in /var/log/messages:

Apr  5 22:45:46 demo kernel: audit(1112766346.171:0): avc:  denied  { read } for  pid=3597 exe=/bin/cp name=config dev=hda2 ino=2261414 scontext=root:system_r:postgresql_t tcontext=user_u:object_r:selinux_config_t tclass=file
Apr  5 22:45:46 demo kernel: audit(1112766346.175:0): avc:  denied  { getattr } for  pid=3597 exe=/bin/cp path=/etc/selinux/config dev=hda2 ino=2261414 scontext=root:system_r:postgresql_t tcontext=user_u:object_r:selinux_config_t tclass=file


Version-Release number of selected component (if applicable):
selinux-policy-targeted-1.23.5-3

How reproducible:
Didn't try

Steps to Reproduce:
1.see above
2.
3.
  

Additional info:

postgresql-8.0.1-5

Comment 1 Daniel Walsh 2005-04-06 11:30:59 UTC
This is not a bug.  Permissive mode gives you more AVC messages then Enforcing.
 Since there is a dontaudit in the postgres rules that would stop it from even
trying to access these files.  



Note You need to log in before you can comment on or make changes to this bug.