Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 153962 - update LE to reflect the latest namespace changes
Summary: update LE to reflect the latest namespace changes
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: iiimf-le-chinput
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Yu Shao
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: IIIMF 154787
TreeView+ depends on / blocked
 
Reported: 2005-04-06 05:44 UTC by Lawrence Lim
Modified: 2014-03-26 00:51 UTC (History)
2 users (show)

Fixed In Version: iiimf-le-chinput-0.3-19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-22 04:15:10 UTC


Attachments (Terms of Use)

Description Lawrence Lim 2005-04-06 05:44:28 UTC
Description of problem:
Due to the recent changes of the namespace in the iiimf library, current chinput
LE has not been updated. As a result, LE cannot be loaded and used.

Version-Release number of selected component (if applicable):
iiimf-le-chinput-0.3-13

How reproducible:
Always

Steps to Reproduce:
1.LANG=zh_CN.UTF-8 gedit
2.CTRL-SPACE to activate LE 
3.
  
Actual results:
Unable to load LE

Expected results:
Able to load LE and enter Simplified Chinese

Additional info:

Comment 1 Jens Petersen 2005-04-12 05:23:24 UTC
Done in 0.3-18.


Comment 2 Jens Petersen 2005-04-12 05:27:37 UTC
<tagoh3> jens: ah, you need to modify IMObjectDescriptorStruct too

Comment 3 Lawrence Lim 2005-04-14 06:05:05 UTC
Thanks for the update jens.

With iiimf-12.1.1-14.svn2476 and iiimf-le-chinput-0.3-18, the LE is now able to
be loaded by the GIMLET. However, whenever there is an attempt to load the LE,
the LE crash the iiimd. Will create another bug for the iiimf-server crashing issue.

Comment 4 Lawrence Lim 2005-04-22 04:15:10 UTC
Confirmed fixed. In iiimf-le-chinput-0.3-19, the LE is installable and usable.


Thanks.


Note You need to log in before you can comment on or make changes to this bug.