Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1539605 - SELinux is preventing abrt-action-lis from 'write' accesses on the súbor /var/lib/rpm/Sha1header.
Summary: SELinux is preventing abrt-action-lis from 'write' accesses on the súbor /var...
Keywords:
Status: CLOSED DUPLICATE of bug 1513720
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:0674250efc8619f2643c5990ae0...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-29 10:07 UTC by edo
Modified: 2018-02-10 09:28 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-07 09:15:40 UTC


Attachments (Terms of Use)

Description edo 2018-01-29 10:07:00 UTC
Description of problem:
SELinux is preventing abrt-action-lis from 'write' accesses on the súbor /var/lib/rpm/Sha1header.

*****  Plugin restorecon (99.5 confidence) suggests   ************************

If you want to fix the label. 
/var/lib/rpm/Sha1header default label should be rpm_var_lib_t.
Then you can run restorecon. The access attempt may have been stopped due to insufficient permissions to access a parent directory in which case try to change the following command accordingly.
Do
# /sbin/restorecon -v /var/lib/rpm/Sha1header

*****  Plugin catchall (1.49 confidence) suggests   **************************

If you believe that abrt-action-lis should be allowed write access on the Sha1header file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'abrt-action-lis' --raw | audit2allow -M my-abrtactionlis
# semodule -X 300 -i my-abrtactionlis.pp

Additional Information:
Source Context                system_u:system_r:abrt_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:var_lib_t:s0
Target Objects                /var/lib/rpm/Sha1header [ file ]
Source                        abrt-action-lis
Source Path                   abrt-action-lis
Port                          <Neznáme>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           rpm-4.13.0.1-7.fc26.x86_64
Policy RPM                    selinux-policy-3.13.1-260.8.fc26.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.12.11-300.fc26.x86_64 #1 SMP Thu
                              Sep 7 18:32:12 UTC 2017 x86_64 x86_64
Alert Count                   2
First Seen                    2017-08-28 14:12:45 CEST
Last Seen                     2017-09-14 11:11:48 CEST
Local ID                      2cb27b49-9f9e-4cec-a4a1-634ea28b84a0

Raw Audit Messages
type=AVC msg=audit(1505380308.867:12853): avc:  denied  { write } for  pid=25185 comm="abrt-action-sav" name="Sha1header" dev="dm-0" ino=1314068 scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:var_lib_t:s0 tclass=file permissive=1


Hash: abrt-action-lis,abrt_t,var_lib_t,file,write

Version-Release number of selected component:
selinux-policy-3.13.1-260.8.fc26.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.3
hashmarkername: setroubleshoot
kernel:         4.14.15-300.fc27.x86_64
type:           libreport

Potential duplicate: bug 1491610

Comment 1 Panu Matilainen 2018-02-07 09:15:40 UTC

*** This bug has been marked as a duplicate of bug 1513720 ***

Comment 2 Artemio 2018-02-10 09:28:03 UTC
*** Bug 1544099 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.